Wave
  1. Wave
  2. WAVE-292

CertpathTest fails as certificate in test has expired expired

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      when running "ant test" the CertpathTest fails as the certificate has expired.

      Here is the stacktrace:

      org.waveprotocol.wave.crypto.SignatureException: Certificate validation failure
      at org.waveprotocol.wave.crypto.CachedCertPathValidator.validateNoCache(CachedCertPathValidator.java:103)
      at org.waveprotocol.wave.crypto.CachedCertPathValidator.validate(CachedCertPathValidator.java:65)
      at org.waveprotocol.wave.crypto.CertpathTest.testValidator_canGrokCriticalExtension(CertpathTest.java:96)
      Caused by: java.security.cert.CertPathValidatorException: timestamp check failed
      at sun.security.provider.certpath.PKIXMasterCertPathValidator.validate(PKIXMasterCertPathValidator.java:139)
      at sun.security.provider.certpath.PKIXCertPathValidator.doValidate(PKIXCertPathValidator.java:328)
      at sun.security.provider.certpath.PKIXCertPathValidator.engineValidate(PKIXCertPathValidator.java:178)
      at java.security.cert.CertPathValidator.validate(CertPathValidator.java:250)
      at org.waveprotocol.wave.crypto.CachedCertPathValidator.validateNoCache(CachedCertPathValidator.java:101)
      Caused by: java.security.cert.CertificateExpiredException: NotAfter: Fri Sep 09 13:28:30 EST 2011
      at sun.security.x509.CertificateValidity.valid(CertificateValidity.java:256)
      at sun.security.x509.X509CertImpl.checkValidity(X509CertImpl.java:570)
      at sun.security.provider.certpath.BasicChecker.verifyTimestamp(BasicChecker.java:157)
      at sun.security.provider.certpath.BasicChecker.check(BasicChecker.java:109)
      at sun.security.provider.certpath.PKIXMasterCertPathValidator.validate(PKIXMasterCertPathValidator.java:117)
      

      When I ran this test I can see that the certificate expired on sep 09.

      java.security.cert.CertificateExpiredException: NotAfter: Fri Sep 09 13:28:30 EST 2011
      

        Activity

        Ali Lown made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hide
        Ali Lown added a comment -

        Fixed a while ago.

        Show
        Ali Lown added a comment - Fixed a while ago.
        Yuri Zelikov made changes -
        Field Original Value New Value
        Priority Blocker [ 1 ] Major [ 3 ]
        Hide
        Yuri Zelikov added a comment -

        Reduced priority, as the issue is not a blocker. It is still possible to build the project by:
        ant compile-gwt dist-server

        Show
        Yuri Zelikov added a comment - Reduced priority, as the issue is not a blocker. It is still possible to build the project by: ant compile-gwt dist-server
        Hide
        Nelson Silva added a comment -

        Can we add a unless="skip.tests" to the build file for now ?

        Show
        Nelson Silva added a comment - Can we add a unless="skip.tests" to the build file for now ?
        Hide
        Jaie Wilson added a comment -

        I found the issue on the mailing list: http://www.mail-archive.com/wave-dev@incubator.apache.org/msg01817.html

        Still would be nice to fix the test.

        Show
        Jaie Wilson added a comment - I found the issue on the mailing list: http://www.mail-archive.com/wave-dev@incubator.apache.org/msg01817.html Still would be nice to fix the test.
        Jaie Wilson created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Jaie Wilson
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development