Wave
  1. Wave
  2. WAVE-260

Random shiny when when clicking on a snippet to load a wave

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Cannot reproduce reliably.
      Stack trace:

      Token: 1303140884546
      Received deltas with no stacklet present!
      Unknown.$fillInStackTrace (StackTraceCreator.java:147)
      Unknown.fillInStackTrace (StackTraceCreator.java:387)
      Unknown.IllegalStateException_1 (Throwable.java:46)
      Unknown.$onUpdate_1 (OperationChannelMultiplexerImpl.java:504)
      Unknown.$onUpdate_2 (ViewChannelImpl.java:329)
      Unknown.onWaveletUpdate_0 (RemoteWaveViewService.java:307)
      Unknown.$onWaveletUpdate (RemoteViewServiceMultiplexer.java:101)
      Unknown.$onMessage_1 (WaveWebSocketClient.java:184)
      Unknown.onMessage (GWTSocketIOConnectionImpl.java:120)
      Unknown.anonymous (GWTSocketIOConnectionImpl.java:17)
      Unknown.entry0 (Impl.java:214)
      Unknown.anonymous (Impl.java:57)


      Issue imported from http://code.google.com/p/wave-protocol/issues/detail?id=261

      Owner: Tad.Glines
      Label: Type-Defect
      Label: Priority-Medium
      Stars: 1
      State: open
      Status: Accepted

        Issue Links

          Activity

          Ali Lown added a comment -

          Related.

          Nikolay Prokofiev added a comment -

          Here is stack from hosted mode

          Stack trace:

          Token: 1307379864179
          Received deltas with no stacklet present!
          org.waveprotocol.wave.concurrencycontrol.channel.OperationChannelMultiplexerImpl$3.onUpdate (OperationChannelMultiplexerImpl.java:504)
          org.waveprotocol.wave.concurrencycontrol.channel.ViewChannelImpl.onUpdate (ViewChannelImpl.java:328)
          org.waveprotocol.box.webclient.client.RemoteWaveViewService.onWaveletUpdate (RemoteWaveViewService.java:307)
          org.waveprotocol.box.webclient.client.RemoteViewServiceMultiplexer.onWaveletUpdate (RemoteViewServiceMultiplexer.java:101)
          org.waveprotocol.box.webclient.client.WaveWebSocketClient.onMessage (WaveWebSocketClient.java:184)
          org.waveprotocol.box.webclient.client.WaveSocketFactory$1$1.onMessage (WaveSocketFactory.java:65)
          com.glines.socketio.client.gwt.GWTSocketIOConnectionImpl.onMessage (GWTSocketIOConnectionImpl.java:120)
          sun.reflect.GeneratedMethodAccessor28.invoke (:)
          sun.reflect.DelegatingMethodAccessorImpl.invoke (DelegatingMethodAccessorImpl.java:25)
          java.lang.reflect.Method.invoke (Method.java:597)
          com.google.gwt.dev.shell.MethodAdaptor.invoke (MethodAdaptor.java:103)
          com.google.gwt.dev.shell.MethodDispatch.invoke (MethodDispatch.java:71)
          com.google.gwt.dev.shell.OophmSessionHandler.invoke (OophmSessionHandler.java:157)
          com.google.gwt.dev.shell.BrowserChannelServer.reactToMessagesWhileWaitingForReturn (BrowserChannelServer.java:326)
          com.google.gwt.dev.shell.BrowserChannelServer.invokeJavascript (BrowserChannelServer.java:207)
          com.google.gwt.dev.shell.ModuleSpaceOOPHM.doInvoke (ModuleSpaceOOPHM.java:126)
          com.google.gwt.dev.shell.ModuleSpace.invokeNative (ModuleSpace.java:561)
          com.google.gwt.dev.shell.ModuleSpace.invokeNativeObject (ModuleSpace.java:269)
          com.google.gwt.dev.shell.JavaScriptHost.invokeNativeObject (JavaScriptHost.java:91)
          com.google.gwt.core.client.impl.Impl.apply (Impl.java:??)
          com.google.gwt.core.client.impl.Impl.entry0 (Impl.java:214)
          sun.reflect.GeneratedMethodAccessor19.invoke (:)
          sun.reflect.DelegatingMethodAccessorImpl.invoke (DelegatingMethodAccessorImpl.java:25)
          java.lang.reflect.Method.invoke (Method.java:597)
          com.google.gwt.dev.shell.MethodAdaptor.invoke (MethodAdaptor.java:103)
          com.google.gwt.dev.shell.MethodDispatch.invoke (MethodDispatch.java:71)
          com.google.gwt.dev.shell.OophmSessionHandler.invoke (OophmSessionHandler.java:157)
          com.google.gwt.dev.shell.BrowserChannelServer.reactToMessages (BrowserChannelServer.java:281)
          com.google.gwt.dev.shell.BrowserChannelServer.processConnection (BrowserChannelServer.java:531)
          com.google.gwt.dev.shell.BrowserChannelServer.run (BrowserChannelServer.java:352)
          java.lang.Thread.run (Thread.java:662)

          Ulrich Stärk added a comment -

          Comment 1 by vega113:
          Tad, can you please take a look at this issue? It seems to be connected with sockets.io

          OwnerUpdate: Tad.Glines


          Comment 2 by ano...@gmail.com:
          The OperationChannelMultiplexer expects to receive a snapshot before any deltas for any particular wavelet. It looks like it's receiving a delta without the preceding snapshot message. The problem could exist somewhere below the mux but also maybe at the server.


            People

            • Assignee:
              Unassigned
              Reporter:
              Anonymous
            • Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development