Wave
  1. Wave
  2. WAVE-252

Single-clicking a blip causes inline replies to appear at the end of the clicked word

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Not a Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      <b>What steps will reproduce the problem?</b>
      1. Single-click a blip in the middle of the text content (without selecting any text)
      2. Press Enter or the "Reply" button
      3. An inline reply will appear after the word that was clicked

      <b>What is the expected output? What do you see instead?</b>
      The reply should appear at the end of the blip when text is not selected. Instead the reply appears in the middle of the blip.

      What changeset or version are you using?
      Most recent as of April 5, 2011.

      On what operating system?
      Confirmed in Google Chrome 11 (beta), Chromium 10 (stable), and Firefox 3.6 on Linux (Ubuntu).


      Issue imported from http://code.google.com/p/wave-protocol/issues/detail?id=253

      Label: Type-Defect
      Label: Priority-Medium
      Stars: 5
      State: open
      Status: New

        Activity

        Jeremy Naegel added a comment - - edited

        This is a really annoying bug form the user-side point of view. A common behavior (if not the most common) is to click on a blip to mark it as read before replying to it. But because of this bug, this untargeted click will become the place where the response is inserted, probably cutting the content you want to reply to in two... This can lead to a huge mess in blips' organisation. IMHO this bug's priority should be higher than "Minor".

        Phil Robinson added a comment -

        Completely agree with Jeremy - I've just run into this and it's incredibly annoying from a user's perspective. I second increasing the priority of this bug!

        Yuri Zelikov added a comment -

        FIxed. waveinabox.net was updated with the fix.

        Phil Robinson added a comment -

        Thanks Yuri. I checked out the codebase onto a clean build machine today, built and running successfully but still the same behavior. Is your code change committed to the codebase? Any flags / switches etc needed to pick it up?

        Phil Robinson added a comment -

        P.S. I obtained the latest code on a clean build machine using git rather than SVN: git clone git://git.apache.org/wave.git <pathtomywavedir>
        Should I be using a different repo / SVN not GIT??

        Yuri Zelikov added a comment -

        The issue is still not resolved in the repo apparently. I ll check what happened.

        Jeremy Naegel added a comment -

        I'm also still experiencing this same behavior on waveinabox.net

        Yuri Zelikov added a comment -

        I just tried again - and I can't reproduce it on waveinabox.net.
        Can someone else also test it?

        Zachary Yaro added a comment -

        I was also seeing the issue on waveinabox.net (as of last night).

        Yuri Zelikov added a comment -

        Here you can see a wave with inline replies that I just created.
        http://waveinabox.net/#waveinabox.net/w+BB9r999MsUB

        Yuri Zelikov added a comment -

        I think I didn't understand the issue. I thought the problem was with creating inline replies, but if I understand it correctly the issue is about clicking causing inline reply instead of thread continuation.
        If so, I just want to note that there's also an option to continue a thread by clicking on the blue footer on the bottom of the blip instead of clicking on "reply".

        Zachary Yaro added a comment -

        True, but unless text is highlighted, people (especially those who used Google Wave or are used to e-mail) are going to expect the reply button to add a message at the end of the current one (whether or not it is at the end of the thread).

        Peter Escamilla added a comment -

        Actually I would expect that when I hit reply when nothing is selected if the blip is the "last" one it should add a blip under it, but if it's a blip in the middle of a chain it should add a indented blip

        Ali Lown added a comment -

        This is a feature, not a bug.


          People

          • Assignee:
            Yuri Zelikov
            Reporter:
            Anonymous
          • Votes:
            4 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development