Uploaded image for project: 'Commons VFS'
  1. Commons VFS
  2. VFS-729

Upgrade hadoop to 2.7.4 or later; will use current 3.2.0

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 2.5.0
    • 2.5.0
    • None

    Description

      The reason why the Travis builds currently fail for JDK 13/EA is due to this Hadoop issue: HADOOP-14586

      I've tested it locally (JDK 13, Build 33) with Hadoop 2.7.4 and all tests pass. As this does bump the Hadoop dependency from 2.6 to >=2.7.4 you probably want to do this for a VFS 2.5 release and in the mean time disable the 13/EA builds in Travis.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            elmuerte Michiel Hendriks
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Issue deployment