Uploaded image for project: 'Commons VFS'
  1. Commons VFS
  2. VFS-686

Upgrade Jackrabbit dependency to the latest 2.x

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 2.2
    • 2.5.0

    Description

      The current dependency, Jackrabbit 1.6.5, still depends on HttpClient 3.x, while Jackrabbit 2.x depends on HttpClient 4.x.
      So, WebDAV file system provider should use the latest stable version of Jackrabbit 2.x.
      As of VFS-360, it is possible to let the WebDAV file system use HttpComponents 4.x.

      Attachments

        1. feature-VFS-686.patch
          647 kB
          Woonsan Ko
        2. feature-VFS-686-2.patch
          647 kB
          Woonsan Ko
        3. feature-VFS-686-3.patch
          652 kB
          Woonsan Ko
        4. feature-VFS-686-4.patch
          674 kB
          Woonsan Ko
        5. feature-VFS-686-5.patch
          674 kB
          Woonsan Ko
        6. feature-VFS-686-6.patch
          675 kB
          Woonsan Ko

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            woon_san Woonsan Ko
            Votes:
            2 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 20m
                20m

                Issue deployment