Uploaded image for project: 'Velocity'
  1. Velocity
  2. VELOCITY-853

Upgrade dependency to commons-collections4

    Details

    • Type: Wish
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.7.x, 1.7
    • Fix Version/s: None
    • Component/s: Engine
    • Labels:
      None

      Description

      org.apache.velocity:velocity:1.7 depends on commons-collections:commons-collections:3.2.1
      https://github.com/apache/velocity-engine/blob/1.7/pom.xml

      org.apache.velocity:velocity:1.7.x depends on commons-collections:commons-collections:3.2.1 also
      https://github.com/apache/velocity-engine/blob/1.7.x/pom.xml

      Please upgrade dependency to org.apache.commons:commons-collections4:4.0

      That will allow using generics in collections classes.

        Attachments

          Activity

            People

            • Assignee:
              claude Claude Brisson
              Reporter:
              koichisenada Ilia Sretenskii
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: