Velocity
  1. Velocity
  2. VELOCITY-61

Problems embedding line comments inside block comments

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-Release
    • Fix Version/s: None
    • Component/s: Engine
    • Labels:
      None
    • Environment:
      Operating System: other
      Platform: Other

      Description

      If you have a regular comment inside a block comment, you will see "#*" (the
      start characters of the block comment) appear on the page.

      1. ASF.LICENSE.NOT.GRANTED--comment.cmp.patch
        0.4 kB
        Will Glass-Husain
      2. ASF.LICENSE.NOT.GRANTED--comment.cmp.patch
        0.4 kB
        Will Glass-Husain
      3. ASF.LICENSE.NOT.GRANTED--comment.vm.patch
        0.5 kB
        Will Glass-Husain
      4. ASF.LICENSE.NOT.GRANTED--comment.vm.patch
        0.5 kB
        Will Glass-Husain
      5. ASF.LICENSE.NOT.GRANTED--Parser.patch
        0.4 kB
        Will Glass-Husain

        Activity

        Geir Magnusson Jr added a comment -

        thanks. ack.

        Will Glass-Husain added a comment -

        This is a bit of an old bug, but here's a fix. Committers, please take note.

        Verified the original problem. Created a patch to fix it with new test
        cases. Seems too simple, but ant test works so I guess it's ok.

        I'm just including a patch to the changed source file Parser.jjt. If I should
        include Parser.java and Parser.jj (generated automatically), let me know.

        Will Glass-Husain added a comment -

        Created an attachment (id=8763)
        patch to Parser.jjt

        Will Glass-Husain added a comment -

        Created an attachment (id=8764)
        Patch to comment.cmp

        Will Glass-Husain added a comment -

        Created an attachment (id=8765)
        patch to comment.vm

        Will Glass-Husain added a comment -

        Also fixes bug# 7382. I'll upload new versions of comment.cmp and comment.vm
        to prove it.

        Will Glass-Husain added a comment -

        Created an attachment (id=8795)
        Patch to comment.vm (replaces previous attachment)

        Will Glass-Husain added a comment -

        Created an attachment (id=8796)
        Patch to comment.cmp (replaces previous attachment)

        Will Glass-Husain added a comment -
            • Bug 7382 has been marked as a duplicate of this bug. ***
        Geir Magnusson Jr added a comment -

        done. thx.

        Henning Schmiedehausen added a comment -

        Close all resolved issues for older releases.


          People

          • Assignee:
            Unassigned
            Reporter:
            Elicia David
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development