Velocity
  1. Velocity
  2. VELOCITY-584

Change the #include directive ignore the SSI version of include

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.5
    • Fix Version/s: 2.x
    • Component/s: Engine
    • Labels:
      None

      Description

      When processing a file that happens to have the SSI version of 'include' in it, the velocity engine breaks.

      There are many cases where we end up with files that contain both, before they are cleaned up.

      <!-#include file="wisdom.inc"->

      Essentially, if it sees that syntax, it needs to ignore the include. A suggestion would be to check for any amount of whitespace after the #include, and then "file=". I don't think that will step on proper Velocity include syntax.

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              Tim White
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development