Velocity
  1. Velocity
  2. VELOCITY-580

Multi line comments simply don't work inside a macro

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: None
    • Component/s: Engine
    • Labels:
      None

      Description

      This very simple macro:

      #macro(tabSection_begin $sectionTitle)
      a
      #*

      test

      *#
      b
      #end

      produces :

      a *# b

      (notice the presence of the end of comment "*#" in the result !)

      This worked as intended in 1.3.1.

        Issue Links

          Activity

          Will Glass-Husain added a comment -

          Thanks for reporting this. Will take a look at it.

          Nathan Bubna added a comment -

          Yeah, i discovered this in my testing of VELOCITY-537. Something screwy happened with macro parsing in 1.5, but i've never been familiar enough with the parsing part of Velocity Engine to figure it out. I may find it in me to prioritize this, but since i don't advocate complicated macros for a variety of reasons (now including this), i'm not especially motivated to dig in here myself.

          Please feel free to check it out yourself, since none of our more parser-savvy community members seem to be jumping on this.

          Nathan Bubna added a comment -

          Marnix van Bochove posted a nice workaround patch that fixes this particular symptom in case VELOCITY-537. If no one comes up with a patch to fix the root problem, then i'll commit that patch to fix this before the next release.

          Will Glass-Husain added a comment -

          applied Marnix's patch to trunk.


            People

            • Assignee:
              Unassigned
              Reporter:
              BoD
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development