Le mardi 28 novembre 2006 à 12:14 -0800, Henning Schmiedehausen (JIRA) a écrit :
> I tried ant -Dforce.jar.loading=1 and force.jar.loading=0 with no success until I found out that it's -Dforce.jar.loading=true that works.
Ant properties allow "on","true" and "yes", but not 1... I guess you should not play lotto this week.
> check ---> Current behaviour. Check for presence, if missing download, if existing, check timestamp.
Are you sure you want to keep this one? There is no point in checking timestamps of versionned filenames.
> But I don't want to have a second (different named, booo!) property whose semantics are different
> from skip.jar.loading (here, presence is enough, for the proposed change the property must actually
> contain the 'True' value) which muddles the options that an user must go through.
I agree that the semantics should be the same, good point (I hadn't noticed this behaviour of the "unless" attribute). But I'd rather have skip.jar.loading semantics modified, because having the property "skip.jar.loading=false" still skiping jar loading looks rather confusing.
Also, your proposal seems much more difficult to document, whereas just putting
skip.jar.loading = false
force.jar.loading = false
inside build.properties is straightforward to anybody taking a look at the file.