Velocity
  1. Velocity
  2. VELOCITY-466

Look into maven plugins for ant to use automatic deployment to maven repositories

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: 1.6
    • Component/s: Build
    • Labels:
      None

      Description

      there are maven plugins that can be driven by ant to automatically deploy the velocity builds to the maven repositories (suggested by Thomas Minor, thanks)

        Issue Links

          Activity

          Nathan Bubna added a comment -

          Adrian Tarau resolved this with his patch for VELOCITY-554.

          Adrian Tarau added a comment -

          Well, there are lots of articles about Maven and most of them have the word "stability" somewhere between the lines(just search for "maven stability"). More or less, stability is linked to the plug-in versions and not to the maven core.

          Included in 2.0.9 is this improvement http://jira.codehaus.org/browse/MNG-3395. Anyway, Maven team recommends to lock your plug-in versions in your POM. I don't think this is necessary for core plugins anymore, 'cause Super-POM will give you the latest stable plug-in(you can always change the version if you notice weird issues with the default version.

          I'm pretty sure for large projects you can hit some road blocks, but nothing that cannot be fixed in a short period of time.

          http://blogs.exist.com/bporter/2008/07/07/maven-is-going-where-you-say/

          I will update Velocity POMs to use Maven 2.0.9 and post the results.

          Henning Schmiedehausen added a comment -

          You are more than welcome to "forward port" the plugins under http://svn.apache.org/viewvc/velocity/site/tools/ to the current minor version 2.0.9 (or .10). They run reasonably well under 2.0.6 so it shouldn't be too hard to get them to run under 2.0.9 I am looking forward to your report about the stability of the Maven core.

          Adrian Tarau added a comment -

          Ups, sorry .. "...not using Velocity 1.6 until 1.7 is stable"

          Adrian Tarau added a comment -

          I agree is not perfect, but still far away from scary. Looks pretty stable to me, at least core plugins(http://maven.apache.org/plugins/index.html).

          Anyway it doesn't matter how good or bad is Maven.I didn't worked with Ant(I've used ant tasks with Maven 1) lately but if nobody take this I can have a look.

          Just a friendly remark : Not using Maven 2.0.9(current version) until 2.3.X is stable is like not using Velocity 1.6 until 1.7 is not stable

          Henning Schmiedehausen added a comment -

          Sorry, but as long as I am on the PMC, I will veto any attempts to move to an "exclusive maven based build" until maven has proven to be stable for at least two minor versions (2.1, 2.2, 2.3 etc.) in a row.

          Feel free to submit an updated POM but expect me to

          • veto any file shuffling for the sake of the build
          • veto any proposal to change the official release builds to use maven
          • veto anything that would risk destabilizing the ant build
          • veto anything that is proven to be unstable in the long run (i.e. not locking down any version of a plugin or dependency completely) in the POM.

          Sorry, been there, done that, got the scars to prove it. Velocity uses ant as its official build system, everything else is bonus.

          What I would very much appreciate is a proposal that would allow the ant build to use the ant-wagon tasks to deploy release and test artifacts to the maven repositories. That is what this ticket is all about.

          Just being "pro Maven" doesn't help much. I am "pro stability".

          Adrian Tarau added a comment -

          You don't trust how Maven 2 runs JUnit tests? Can you please enumerate what types of issues did you had with Maven? Maybe I can help with something...

          Anyway, I'm pro Maven so when you need help, let me know.

          Nathan Bubna added a comment -

          We use the pom as our pom, but that's about it for official use of it. The pom could certainly use improvement (things like the JIRA issues links don't work on the changes-report it generates, and i'm not sure if it runs the tests well), but we probably won't be giving up ant yet. There are concerns about the reproducibility of builds with it, and i, at least, am generally annoyed with it due to association with the velocity-site module issues.

          Adrian Tarau added a comment -

          The project seems to have a Maven 2 POM, I presume is not used yet. Do you need some help to move Velocity on M2?

          Nathan Bubna added a comment -

          My understanding is that this would be because we do not do our official release builds with Maven. Official releases are still built with Ant for the foreseeable future. We would want to deploy the Ant-built jars.

          Adrian Tarau added a comment -

          I have experience with Maven, but I'm not sure I understand the request. Why to use ant tasks to deploy velocity to the maven repositories? Maven already has support for something like that(see http://maven.apache.org/plugins/maven-deploy-plugin/index.html).

          Henning Schmiedehausen added a comment -

          Still on my list, however, the ant tasks have ~800 k so improvement must be worthwhile and our current download works pretty well. nyway, missed the 1.5 boat.


            People

            • Assignee:
              Henning Schmiedehausen
              Reporter:
              Henning Schmiedehausen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development