Velocity
  1. Velocity
  2. VELOCITY-284

MethodInvocationException is handled inconsistently

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4, 1.5
    • Fix Version/s: 1.5
    • Component/s: Engine
    • Labels:
      None
    • Environment:
      Operating System: All
      Platform: Other

      Description

      It appears that the exception handling is different depending on whether the
      method is invoked as a passed parameter to a velocimacro or just in a template.

      Ex.

      #doTextLink( $

      {myObj.exception})

      ${myObj.exception}

      The first #doTextLink macro will throw an exception, but it will be logged and
      ignored. However, the second invocation will throw the exception properly.

      I have a patch that should fix this behavior. The exception just needs to be
      rethrown up the call stack. A small signature change to a couple of methods.

      Thanks,

      Mike Rettig

        Activity

        Henning Schmiedehausen added a comment -

        Close all resolved issues for Engine 1.5 release.

        Will Glass-Husain added a comment -

        rsolved again. r473363

        Henning Schmiedehausen added a comment -

        As we already did the scary thing (rebasing VelocityException), we might as well look into catching the exception. Will, can you take a look at that?

        Nathan Bubna added a comment -

        That's a good question. I can't think of any likely problems offhand, but it does give me a sense of foreboding.

        Will Glass-Husain added a comment -

        Question

        – are there any good backwards-compatibility arguments against making VelocityException based on a RuntimeException?

        Henning Schmiedehausen added a comment -

        There are a number of options on this for 1.6:

        • We could do the scary thing. Rebase VelocityException from Exception to RuntimeException. Then catch MethodInvocationException explicitly on
          top of the chain.
        • We could do the less scary thing of creating VelocityRuntimeException similar to VelocityException and rebase just MethodInvocationException.
        • We could create a new RuntimeMethodInvocationException (don't).

        Mike: Do you have a unit test handy for that change?

        Will Glass-Husain added a comment -

        Reversed patch. Revision #151591.

        Will Glass-Husain added a comment -

        Reopened the bug. Can't apply this patch in current version - it changes the
        Context interface which breaks compatibility. Reversed the patch.

        We can leave this open as a reminder to consider for v2.0. Or maybe there's
        an alternative way of handling this.

        Will Glass-Husain added a comment -

        Thanks for the fix. Patch applied. Revision #151478

        Mike Rettig added a comment -

        Sorry, I don't have time to create a new diff. However, the code change is not
        difficult. The only change is to rethrow an exception instead of swallowing it.

        Here is where to start. Change "return null" to "throw mie". Then change the
        method signatures to add the throws clause.

        RCS file:
        /home/cvspublic/jakarta-velocity/src/java/org/apache/velocity/runtime/directive/VMProxyArg.java,v
        retrieving revision 1.17
        diff -r1.17 VMProxyArg.java
        242,243c242
        < public Object getObject( InternalContextAdapter context )
        < {

        > public Object getObject( InternalContextAdapter context ) throws
        MethodInvocationException {
        343,344c342
        <
        < return null;

        > throw mie;

        Will Glass-Husain added a comment -

        Mike,

        Thanks for posting this. Looks like a useful patch. Would you have time to
        redo this patch using unified format (-u option)? If you do that I'll commit
        this.

        You might find this handy.
        http://wiki.apache.org/jakarta-velocity/GettingYourPatchCommitted

        Thanks.

        Shinobu Kawai added a comment -
            • Bug 30219 has been marked as a duplicate of this bug. ***
        Mike Rettig added a comment -

        Created an attachment (id=12177)
        Patch file created against cvs HEAD to rethrow exception.


          People

          • Assignee:
            Will Glass-Husain
            Reporter:
            Mike Rettig
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development