Uploaded image for project: 'Commons Validator'
  1. Commons Validator
  2. VALIDATOR-323

Class not found "org.apache.commons.validator.ValidatorTestSuite"

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 1.4.0 Release
    • Fix Version/s: None
    • Component/s: Framework
    • Labels:
    • Environment:

      Gentoo Linux, trying to package this new version.

      Description

      When running the tests, the class "org.apache.commons.validator.ValidatorTestSuite" is not found; compile.tests was run succesfully.

      `grep -ri suite` and `find . -name '*suite*'` in the project's directory yield nothing of interest, before and after compilation; only:

      build.xml: <arg value="org.apache.commons.validator.ValidatorTestSuite"/>
      build.xml: <arg value="org.apache.commons.validator.routines.checkdigit.CheckDigitTestSuite"/>
      build.xml: <arg value="org.apache.commons.validator.routines.RoutinesTestSuite"/>
      checkstyle.xml: We feel this implementation is well suited as a warning,

      So, where has the test suite gone to?

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              tomwij Tom Wijsman
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 2m
                2m
                Remaining:
                Remaining Estimate - 2m
                2m
                Logged:
                Time Spent - Not Specified
                Not Specified