Commons Validator
  1. Commons Validator
  2. VALIDATOR-158

[validator] Field::validate() cannot be invoked from user-defined code

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: Nightly Builds
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      The org.apache.commons.validator.Field::validate() has package local visibility.
      This prevent the developer code to leverage this method from its code to perform
      a validation for a specific field only (which may be used independently of any
      Form).

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Resolved Resolved Closed Closed
        868d 16h 43m 1 Henri Yandell 12/Nov/07 19:25
        Henri Yandell made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Henri Yandell made changes -
        Affects Version/s Nightly Builds [ 12311748 ]
        Henri Yandell made changes -
        Assignee Jakarta Commons Developers Mailing List [ commons-dev@jakarta.apache.org ]
        Key COM-2185 VALIDATOR-158
        Component/s Validator [ 12311135 ]
        Affects Version/s Nightly Builds [ 12311648 ]
        Project Commons [ 12310458 ] Commons Validator [ 12310494 ]
        Henri Yandell made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 35508 12342337
        Don Brown added a comment -
            • COM-1043 has been marked as a duplicate of this bug. ***
        Don Brown added a comment -

        Added in changeset [239525]. Thanks.

        Jérôme Beau created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Jérôme Beau
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development