Commons Validator
  1. Commons Validator
  2. VALIDATOR-117

[validator] DTDs are not in the 1.1.3 source tar ball, although build.xml expects to find them

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1.1 (alpha)
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: PC

      Description

      I am trying to build 1.1.3 from sources (for an update of the jpackage.org RPM)
      and the build fails because the build.xml file expects to find the DTDs in
      conf/share/ but this not anylonger in the source tar ball (1.1.3). It used to
      be there in the 1.0.2 tar ball.

        Activity

        Fernando Nasser added a comment -

        It seems that when using the new struts 1.2.4 (instead of the old 1.1) some
        applications end up causing Tomcat 5.0.27 to attempt to use a new constructor
        that is not in the 1.0.2 version ov validator.

        So we now <desperately> need to build a validator 1.1.3 JPackage.

        Can someone please suggest a work around? Can we copy the files from 1.0.2 and
        drop in conf/share? Can I patch the build.xml file somehow so it does not look
        for these DTDs? Where the DTDs should come from by the way?

        Thanks in advance for your help.

        Fernando Nasser added a comment -

        Validator 1.0.4 source tar ball still lacks the conf subdirectory.

        At least this directory is tagged with VALIDATOR_1_1_4 in svn, but it still did
        not make it into thetarball.

        To build, we are having to retrieve it from svn and re-add it to the source tree
        before building.

        Could someone please fix this?

        Thanks in advance.

        Don Brown added a comment -

        I don't believe the Ant build is supported anymore, but I could be wrong. I've
        been using Maven this whole time and haven't had any problems. I'm marking this
        as an enhancement until shown otherwise. Let me know if the Maven build is
        missing something.

        Niall Pemberton added a comment -

        The problem is in the maven build (ant seems to be OK) - as well as the DTD's,
        the xdocs were also not being copied into the source distro.

        I have fixed the maven build (and ported the change to the
        VALIDATOR_1_1_2_BRANCH branch) - thanks Fernando for pointing this out.

        Fernando Nasser added a comment -

        Thank you very much for fixing it.


          People

          • Assignee:
            Unassigned
            Reporter:
            Fernando Nasser
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development