Uploaded image for project: 'UIMA'
  1. UIMA
  2. UIMA-5244

Problem moved to UIMA-5283 -- was: SM sometimes keeps starting failing instances forever

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.0-Ducc
    • Component/s: DUCC
    • Labels:
      None

      Description

      If multiple instances of a service are started and some fail before all have been started, the SM will keep restarting instances and ignores the init-failure limit.
      When staring 10 with an init-failure limit of 1 it created >100 instances ... only an unregister stopped it.

        Activity

        burn Burn Lewis added a comment -

        Changing the number of instances to 1 didn't stop it. That changed "registered_instances", while "instances" stayed at the initial value.

        burn Burn Lewis added a comment -

        Added check of disabled to the check for unregistered when starting multiple instances. Also ensure that stop stops all by setting the target instances to 0.

        burn Burn Lewis added a comment -

        Changing the registered instances to 1 does not change the original target instance of 6. By design changing the registration is not meant to affect running instances ... which means not stopping them!

        burn Burn Lewis added a comment -

        For complex reasons this fix exposes a problem in restarting services when DUCC is bounced. Some previously running service instances are presented as having failed so the SM falsely disables the service. This fix must be backed out.

        burn Burn Lewis added a comment -

        Backed out check for disabled as when restarting a service after a full bounce the SM must ignore the false failures reported for the previously running instances saved in the OR checkpoint.

        burn Burn Lewis added a comment -

        Found one more change that should have been backed out. Problem transferred to UIMA-5283

        burn Burn Lewis added a comment -

        Ref started services work again


          People

          • Assignee:
            burn Burn Lewis
            Reporter:
            burn Burn Lewis
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development