Uploaded image for project: 'UIMA'
  1. UIMA
  2. UIMA-5152

DUCC may let a JP grab some WIs if pre-empted just as initilization completes

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.0-Ducc
    • Component/s: DUCC
    • Labels:
      None

      Description

      If the kill comes just before the JP completes it will go ahead and fetch WIs which then will fail.

      21 Oct 2016 09:19:19,239 INFO JobProcessComponent - T[39] setState Notifying Agent New State:Running
      21 Oct 2016 09:19:19,275 INFO JobProcessComponent - T[30] start DUCC Service Caught Kill Signal - Registering Killer Task and Stopping ...
      21 Oct 2016 09:19:19,366 INFO AgentSession - T[39] notifyAgentWithStatus ... Job Process State Changed - PID:18185. Process State: Running. JMX Url:service:jmx:rmi:///jndi/rmi://bluej605.bluej.net:2120/jmxrmi Dispatched State Update Event to Agent with IP:192.168.4.8
      21 Oct 2016 09:19:19,367 INFO HttpWorkerThread - T[39] HttpWorkerThread.run() Begin Processing Work Items - Thread Id:39
      21 Oct 2016 09:19:19,367 WARN HttpWorkerThread - T[39] run EXITING WorkThread ID:39
      EXITING WorkThread ID:39
      21 Oct 2016 09:19:19,367 INFO JobProcessComponent - T[37] setState Notifying Agent New State:Running
      21 Oct 2016 09:19:19,402 INFO HttpWorkerThread - T[37] HttpWorkerThread.run() Begin Processing Work Items - Thread Id:37
      21 Oct 2016 09:19:19,403 INFO HttpWorkerThread - T[38] HttpWorkerThread.run() Begin Processing Work Items - Thread Id:38
      21 Oct 2016 09:19:19,403 INFO HttpWorkerThread - T[36] HttpWorkerThread.run() Begin Processing Work Items - Thread Id:36
      21 Oct 2016 09:19:22,096 INFO HttpWorkerThread - T[37] run Thread:37 Recv'd WI:775
      21 Oct 2016 09:19:22,106 INFO HttpWorkerThread - T[38] run Thread:38 Recv'd WI:774
      21 Oct 2016 09:19:22,200 INFO HttpWorkerThread - T[36] run Thread:36 Recv'd WI:776
      org.apache.uima.analysis_engine.AnalysisEngineProcessException

      Caused by: java.lang.Exception: Uima EE Client Not In Running State

        Activity

        cwiklik Jerry Cwiklik added a comment -

        Fix a bug which allowed state transition from Stopping to Running again


          People

          • Assignee:
            Unassigned
            Reporter:
            burn Burn Lewis
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development