Uploaded image for project: 'UIMA'
  1. UIMA
  2. UIMA-4972

UIMA-DUCC: modify uima-as dd2spring.xsl to remove scope="singleton"

    Details

    • Type: Task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1.0-Ducc
    • Component/s: DUCC
    • Labels:
      None

      Description

      UIMA-AS 2.8.1 comes with a modified version of dd2spring.xsl which is not backwards compatible with previous versions of UIMA-AS. The problem is that bean scope=singleton is not a valid attribute in older versions of Spring framework. The documentation clearly says it is supported yet when running with older version of Spring the setting scope="singleton" causes the following exception:

      Caused by: org.xml.sax.SAXParseException; lineNumber: 63; columnNumber: 28; Attribute "scope" must be declared for element type "bean".

      Modify DUCC's root pom to change dd2spring.xsl supplied by UIMA-AS 2.8.1 by replacing offending attribute (scope="singleton") with an empty string.

        Attachments

          Activity

            People

            • Assignee:
              cwiklik Jerry Cwiklik
              Reporter:
              cwiklik Jerry Cwiklik
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: