Uploaded image for project: 'UIMA'
  1. UIMA
  2. UIMA-4091

upgrade Java version for UIMAJ-SDK to 7

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.6.0SDK
    • Fix Version/s: 2.7.0SDK
    • Component/s: Core Java Framework
    • Labels:
      None

      Description

      Some code now requires methods only available in Java 7, and Java 6 ended its public support period last year. Upgrade to 7.

        Activity

        Hide
        rec Richard Eckart de Castilho added a comment -

        Might be worth enforcing that as a minimum JDK level with the maven-enforcer-plugin too (if we don't already do that).

        Show
        rec Richard Eckart de Castilho added a comment - Might be worth enforcing that as a minimum JDK level with the maven-enforcer-plugin too (if we don't already do that).
        Hide
        schor Marshall Schor added a comment -

        Also (thanks to Peter Klügl), update poms that specify Bundle-RequiredExecutionEnvironment for java 7 for Eclipse plugins which have this dependency

        Show
        schor Marshall Schor added a comment - Also (thanks to Peter Klügl), update poms that specify Bundle-RequiredExecutionEnvironment for java 7 for Eclipse plugins which have this dependency

          People

          • Assignee:
            schor Marshall Schor
            Reporter:
            schor Marshall Schor
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development