Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0TextMarker
    • Fix Version/s: 2.0.0TextMarker
    • Component/s: ruta
    • Labels:
      None

      Description

      It would be nice if there was a Jenkins build for TextMarker on https://builds.apache.org and if snapshot versions would automatically be deployed to some snapshot repository.

        Activity

        deprecated (use "rec") created issue -
        Peter Klügl added a comment -

        Yes, I agree. However, I am a bit undecided if this should be done before or after the 2.0.0 release and if I should yet change how the eclipse bundles are built (although this should be temporarily less problematic with your repository).

        Peter Klügl made changes -
        Field Original Value New Value
        Affects Version/s 2.0.0TextMarker [ 12323872 ]
        deprecated (use "rec") added a comment -

        The repo should permit a Jenkins build, but currently I am having problems building TextMarker on Jenkins. For some reason, the artifacts version ranges are not correctly resolved. While dltk core 3.0.1 should be used, Maven tries to use dltk 3.0.0 which isn't in the repository. I don't have that problem on the command line.

        Peter Klügl added a comment -

        I have no idea yet what the problem could be.

        Peter Klügl added a comment - - edited

        @Marshall: builds.apache.org says that the PMC chair should be asked in order to get access. Can you add me to the hudson-jobadmin group sometime? No hurry at all, I just wanted to mention it.

        deprecated (use "rec") added a comment -

        After deleting ~/.m2/repository, the build runs fine.

        Peter Klügl added a comment -

        Nice. You can probably answer me some question, if I have problems with the apache jenkins?

        deprecated (use "rec") added a comment -

        Probably

        Peter Klügl made changes -
        Assignee Peter Klügl [ pkluegl ]
        deprecated (use "rec") added a comment -

        I experimented a bit more with the Jenkins build. It works with the simple "clean install" goals. But when I add any of the additional goals that I usually use (javadoc:aggregate, dependency:analyze or cobertura:cobertura) the build fails because Maven claims it cannot find DLTK Core version 3.0. I guess many Maven plugins don't really do well with version ranges.

        deprecated (use "rec") added a comment -

        Peter Klügl would you like me to set up a build on the Apache Jenkins? I have permissions now to create jobs.

        Peter Klügl added a comment -

        That would be great (and very nice of you)

        deprecated (use "rec") added a comment -

        I will do some minor changes to the source code. I don't know why, but the javac (JDK 1.6 latest) on the Apache Jenkins server seems to choke on tailing commata in array initializations. Possibly it is an IBM JDK, not an Oracle/Sun JDK, even though the IBM JDK is another explicit choice that can be made.

        Also, there is still the problem with the version ranges which seems to prevent running code quality checks. Would you mind if I change the version range for DLKT from [3.0.0 to [3.0.1?

        deprecated (use "rec") added a comment -

        Added Jenkins build:

        With plugins running:

        • PMD/CPD (Maven/Jenkins)
        • Findbugs (Maven/Jenkins)
        • Open issues (Jenkins)
        • Compiler warnings (Jenkins)
        • JavaDoc warnings (Jenkins)
        • Deployment of snapshots to Maven repository

        Cobertura doesn't run. Once I add that, Maven complains again about the DLTK version 3.0.0. For this reason I'm leaving the issue open for now.

        deprecated (use "rec") made changes -
        Assignee Peter Klügl [ pkluegl ] Richard Eckart de Castilho [ eckart ]
        Marshall Schor added a comment -

        Peter - I added you to the hudson-jobadmin group so you can administer the TextMarker builds. You need to subscribe (if you haven't already done so) to the infrastructure and builds mailing list (see http://wiki.apache.org/general/Jenkins?action=show&redirect=Hudson#How_do_I_get_an_account )

        Peter Klügl added a comment -

        Thanks Marshall. Yes, I already have subscribed to those mailing lists.

        Peter Klügl added a comment -

        Thanks Richard. I remember that I had problems when creating the maven build process for the bundles, and these problems were caused by the version range [3.0.0 for all bundles. So I have changed it to [3.0.1 for those that are provided by indigo with that version. Maybe it was only a mistake on my side, but I want to test the workbench in action before we switch back to [3.0.0. I will take a look at it next week.

        deprecated (use "rec") added a comment -

        Peter Klügl, try running Cobertura on the command line with the new versions to see if it helps:

        $ mvn clean install cobertura:cobertura
        
        Peter Klügl added a comment -

        I fixed the dependencies of the addons project.

        $ mvn clean install cobertura:cobertura
        

        now finishes successfully.

        deprecated (use "rec") added a comment -

        Added Cobertura run and report to the Jenkins build. Works fine now.

        deprecated (use "rec") made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.0.0TextMarker [ 12323872 ]
        Resolution Fixed [ 1 ]
        Richard Eckart de Castilho made changes -
        Assignee Richard Eckart de Castilho [ eckart ] Richard Eckart de Castilho [ rec ]
        Richard Eckart de Castilho made changes -
        Reporter Richard Eckart de Castilho [ eckart ] Richard Eckart de Castilho [ rec ]
        Peter Klügl made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Richard Eckart de Castilho
            Reporter:
            Richard Eckart de Castilho
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development