UIMA
  1. UIMA
  2. UIMA-2487

Optimize UIMA-AS code that collects pipeline stats

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.4.0AS
    • Component/s: Async Scaleout
    • Labels:
      None

      Description

      When collecting stats from AE Management objects the UIMA-AS needs to create a snapshot of stats before calling AE process method. It actually does a deep copy (by serialization) of Management objects. This snapshot is used to calculate component analysis time when the process method completes. The problem is that the serialization is adding too much overhead and actually is not necessary. Refactor code to avoid serialization overhead.

        Activity

        Jerry Cwiklik created issue -
        Jerry Cwiklik added a comment -

        Refactored code to avoid serialization. Instead of serializing (deep copy), a new object is created and initialized with values from a Management object.

        Jerry Cwiklik made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Jerry Cwiklik [ cwiklik ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Jerry Cwiklik
            Reporter:
            Jerry Cwiklik
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development