UIMA
  1. UIMA
  2. UIMA-2366

Eclipse 3.7, Uima 2.4.0 - Eclipse update site not working

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.4.0SDK
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Eclipse 3.7, OS X 10.7.3

      Description

      It appears that the http://www.apache.org/dist/uima/eclipse-update-site is not currently available. Not found errors when attempting to access. Is this the correct way to install the eclipse plugin?

        Activity

        Hide
        Marshall Schor added a comment -

        I just tried it, and it worked for me. Perhaps the site was down (temporarirly).

        There is one (known) issue: The SDK has been released at 2.4.0 UIMA-AS (and its Eclipse plugin) have not yet been released at 2.4.0, but are still at 2.3.1.

        The deployment descriptor editor (part of UIMA-AS) (at version 2.3.1) depends on the base component descriptor editor at the same version level. Therefore, if you want to install all of the Eclipse plugs for UIMA, you must install the 2.3.1 versions. If you install the 2.4.0 version of the uima runtime and tooling, by itself, that will install OK, but then you won't be able to install the UIMA-AS Deployment Descriptor Editor.

        Show
        Marshall Schor added a comment - I just tried it, and it worked for me. Perhaps the site was down (temporarirly). There is one (known) issue: The SDK has been released at 2.4.0 UIMA-AS (and its Eclipse plugin) have not yet been released at 2.4.0, but are still at 2.3.1. The deployment descriptor editor (part of UIMA-AS) (at version 2.3.1) depends on the base component descriptor editor at the same version level. Therefore, if you want to install all of the Eclipse plugs for UIMA, you must install the 2.3.1 versions. If you install the 2.4.0 version of the uima runtime and tooling, by itself, that will install OK, but then you won't be able to install the UIMA-AS Deployment Descriptor Editor.
        Hide
        Joern Kottmann added a comment -

        I just tried that today and it worked for me as well without any issues. I used eclipse 3.7 and uima 2.4.0 on Linux.

        Show
        Joern Kottmann added a comment - I just tried that today and it worked for me as well without any issues. I used eclipse 3.7 and uima 2.4.0 on Linux.

          People

          • Assignee:
            Unassigned
            Reporter:
            Michael Kilgore
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development