UIMA
  1. UIMA
  2. UIMA-1751

Fix NPE while looking up MessageProducer

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3AS
    • Fix Version/s: 2.3.1AS
    • Component/s: Async Scaleout
    • Labels:
      None

      Description

      ActiveMQMessageSender throws NPE in getMessageProducer() sometimes when the UIMA AS client is stopping. A race condition seems to be the cause. A thread doing a send tries to dereference engine object after the engine was forced to stop.

        Activity

        Jerry Cwiklik added a comment -

        Modified getMessageProducer() in ActiveMQMessageSender to check the state of the engine before returning the Producer.


          People

          • Assignee:
            Unassigned
            Reporter:
            Jerry Cwiklik
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development