UIMA
  1. UIMA
  2. UIMA-1742

UIMA AS Aggregate not exposing number of consumer threads on its delegate's reply queues

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3AS
    • Fix Version/s: 2.3.1AS
    • Component/s: Async Scaleout
    • Labels:
      None

      Description

      UIMA AS Spring listener uses a single thread per delegate to handle replies. If a deployment descriptor is configured to process replies using multiple threads, the UIMA AS creates a concurrent listener with a thread pool to which the single-threaded Spring listener delegates all reply messages. This logic was added to assure that the parent CAS is always processed ahead of its children. The problem is that a JMX console shows a single JMS Consumer on a reply queue. This is correct, but the number of threads in the concurrent listener should be shown in the UIMA AS MBeans.

        Activity

        Jerry Cwiklik added a comment -

        Added support for a new JMX property - ReplyThreadCount to service Performance MBean. Also, added log message identifying number of consumers on a reply queue. Updated docs to include the new JMX property on service Performance MBean.


          People

          • Assignee:
            Jerry Cwiklik
            Reporter:
            Jerry Cwiklik
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development