UIMA
  1. UIMA
  2. UIMA-1710

All projects should fail if not compiled with at least maven 2.2.0

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.3S, 2.3, 2.3AS
    • Fix Version/s: None
    • Labels:
      None

      Description

      Right now the build fails if uimaj is build with a maven version prior 2.2.0, but it does not fail in other projects.

      If a maven version prior 2.2.0 is used the build should fail with the invalid version error message in
      all projects, instead of:
      [INFO] Error configuring: org.apache.maven.plugins:maven-antrun-plugin. Reason: java.lang.NoSuchMethodError: org.apache.tools.ant.util.FileUtils.close(Ljava/io/InputStream;)V

        Activity

        Marshall Schor made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Joern Kottmann created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Joern Kottmann
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development