Uploaded image for project: 'Apache Twill'
  1. Apache Twill
  2. TWILL-249

Upgrade Twill to use newer version of kafka_2.10

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Currently to work around issue with secure cluster and how zkclient handles it we have https://issues.apache.org/jira/browse/TWILL-139

      Since that time zkcient was fixed (fix in version 0.7)

      But Twill still uses old version of kafka 0.8 that relies on 0.3 version of zkclient.
      zkclient version 0.7 is included as a dependency since kafka 0.9.0.0.
      That version of kafka introduces changes to APIs though.

      This JIRA is to upgrade to later version of Kafka.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              yufeldman Yuliya Feldman
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: