Uploaded image for project: 'Apache Twill'
  1. Apache Twill
  2. TWILL-163

LocationFactory.getHomeLocation method returns home location of the user running the application instead of the user that owns the hdfs directories.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.6.0-incubating
    • Fix Version/s: 0.8.0
    • Component/s: core, yarn
    • Labels:
      None

      Description

      Location.getHomeLocation() method returns the home location of the current user(who is running the application). It should return the home location of the user who owns the hdfs directories.

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/incubator-twill/pull/78

          githubbot ASF GitHub Bot added a comment -

          Github user albertshau commented on the pull request:

          https://github.com/apache/incubator-twill/pull/78#issuecomment-219801600

          lgtm

          githubbot ASF GitHub Bot added a comment -

          GitHub user chtyim opened a pull request:

          https://github.com/apache/incubator-twill/pull/78

          (TWILL-163) Fix FileContextLocationFactory to honor UGI for home location

          • Also include removal on usage of the deprecated HDFSLocationFactory

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/chtyim/incubator-twill feature/TWILL-163

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/incubator-twill/pull/78.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #78


          commit a4a2b3e2139433176c1da708725ebce55f9596b5
          Author: Terence Yim <chtyim@apache.org>
          Date: 2016-01-28T20:36:14Z

          (TWILL-163) Fix FileContextLocationFactory to honor UGI for home location

          • Also include removal on usage of the deprecated HDFSLocationFactory

          chtyim Terence Yim added a comment -

          the problem is FileContext.getHomeDirectory doesn't honor the current UGI.


            People

            • Assignee:
              chtyim Terence Yim
              Reporter:
              sagark Sagar Kapare
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development