Tuscany
  1. Tuscany
  2. TUSCANY-3589

Domain manager produces "get - Error getting data" message when doing a search

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Java-SCA-1.6
    • Fix Version/s: Java-SCA-1.x
    • Component/s: SCA Java Runtime
    • Labels:
      None

      Description

      When performing a search in the Domain Manager GUI, an error popup "get - Error getting data from the server" is produced and no search results are returned.

        Activity

        Simon Nash added a comment -

        The problem is caused by a NoSuchMethodError thrown by the Searcher.java file of modules/domain-manager. This is because this file uses the org.apache.commons.lang.StringEscapeUtils.escapeHtml() method which requires commons-lang-2.3. The Tuscany SCA Java 1.6 binary distribution contains commons-lang-2.1 instead of commons-lang-2.3, so the escapeHtml() method isn't found.

        Fixed under revision r951571 by updating distribution/bundle/pom.xml to remove the dependency from tuscany-implementation-bpel-ode to commons-lang-2.1. This causes commons-lang-2.3 to be brought in via the dependency from tuscany-domain-manager.


          People

          • Assignee:
            Simon Nash
            Reporter:
            Simon Nash
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development