Tuscany
  1. Tuscany
  2. TUSCANY-192

intermittent build failure: java.lang.IllegalArgumentException: wrong number of arguments

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      [java.lang.IllegalArgumentException: wrong number of arguments
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tuscany.container.java.invocation.AbstractJavaComponentInv
      oker.invokeTarget(AbstractJavaComponentInvoker.java:58)
      at org.apache.tuscany.container.java.invocation.AbstractJavaComponentInv
      oker.invoke(AbstractJavaComponentInvoker.java:67)
      at org.apache.tuscany.binding.axis2.builder.WebServiceEntryPointBuilder$
      EntryPointInvokerInterceptor.invoke(WebServiceEntryPointBuilder.java:160)
      at org.apache.tuscany.core.invocation.jdk.JDKInvocationHandler.invoke(JD
      KInvocationHandler.java:120)
      at org.apache.tuscany.binding.axis2.handler.WebServiceEntryPointInOutSyn
      cMessageReceiver.invokeBusinessLogic(WebServiceEntryPointInOutSyncMessageReceive
      r.java:88)
      at org.apache.axis2.receivers.AbstractInOutSyncMessageReceiver.receive(A
      bstractInOutSyncMessageReceiver.java:37)
      at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:408)
      at org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostReq
      uest(HTTPTransportUtils.java:288)
      at org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:1
      60)
      at org.apache.tuscany.binding.axis2.handler.WebServiceEntryPointServlet.
      doPost(WebServiceEntryPointServlet.java:235)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:763)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
      icationFilterChain.java:252)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
      ilterChain.java:173)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
      alve.java:213)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
      alve.java:178)
      at org.apache.tuscany.tomcat.TuscanyValve.invoke(TuscanyValve.java:87)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
      ava:126)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
      ava:105)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:869)

      at org.apache.tuscany.tomcat.integration.TomcatIntegrationTestCase.testW
      ebServiceIntegration(TomcatIntegrationTestCase.java:92)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at junit.framework.TestCase.runTest(TestCase.java:154)
      at junit.framework.TestCase.runBare(TestCase.java:127)
      at junit.framework.TestResult$1.protect(TestResult.java:106)
      at junit.framework.TestResult.runProtected(TestResult.java:124)
      at junit.framework.TestResult.run(TestResult.java:109)
      at junit.framework.TestCase.run(TestCase.java:118)
      at junit.framework.TestSuite.runTest(TestSuite.java:208)
      at junit.framework.TestSuite.run(TestSuite.java:203)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.maven.surefire.battery.JUnitBattery.executeJUnit(JUnitBatt
      ery.java:242)
      at org.apache.maven.surefire.battery.JUnitBattery.execute(JUnitBattery.j
      ava:216)
      at org.apache.maven.surefire.Surefire.executeBattery(Surefire.java:215)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:163)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:87)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.maven.surefire.SurefireBooter.runTestsInProcess(SurefireBo
      oter.java:313)
      at org.apache.maven.surefire.SurefireBooter.run(SurefireBooter.java:221)

      at org.apache.maven.test.SurefirePlugin.execute(SurefirePlugin.java:371)

      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPlugi
      nManager.java:412)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa
      ultLifecycleExecutor.java:534)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLi
      fecycle(DefaultLifecycleExecutor.java:475)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau
      ltLifecycleExecutor.java:454)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan
      dleFailures(DefaultLifecycleExecutor.java:306)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen
      ts(DefaultLifecycleExecutor.java:273)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
      fecycleExecutor.java:140)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:322)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:115)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:256)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)

      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Apr 14, 2006 10:38:02 AM org.apache.tuscany.tomcat.TuscanyHost stopRuntime
      INFO: Stopped Tuscany runtime
      [surefire] Running org.apache.tuscany.tomcat.integration.TomcatIntegrationTestCa
      se
      [surefire] Tests run: 2, Failures: 1, Errors: 0, Time elapsed: 5.391 sec
      [surefire]
      [surefire] testWebServiceIntegration(org.apache.tuscany.tomcat.integration.Tomca
      tIntegrationTestCase) Time elapsed: 0.984 sec <<< FAILURE!
      junit.framework.ComparisonFailure: expected:<...helloworldaxis:getGreetingsRespo
      nse xmlns:helloworldaxis="http://helloworldaxis.samples.tuscany.apache.org">
      <helloworldaxis:getGreetingsReturn>Hello World</helloworldaxis:getGreetingsRet
      urn>
      </helloworldaxis:getGreetingsResponse...> but was:<...soapenv:Fault><faultcode>s
      oapenv:Client</faultcode><faultstring>Error creating DataObject from Soapenvelop
      e. class java.lang.IllegalArgumentException wrong number of arguments; nested ex
      ception is:
      java.lang.IllegalArgumentException: wrong number of arguments</faultstri
      ng><detail><Exception xmlns="">org.apache.axis2.AxisFault: Error creating DataOb
      ject from Soapenvelope. class java.lang.IllegalArgumentException wrong number of
      arguments; nested exception is:
      java.lang.IllegalArgumentException: wrong number of arguments
      at org.apache.tuscany.binding.axis2.handler.WebServiceEntryPointInOutSyn
      cMessageReceiver.invokeBusinessLogic(WebServiceEntryPointInOutSyncMessageReceive
      r.java:104)
      at org.apache.axis2.receivers.AbstractInOutSyncMessageReceiver.receive(A
      bstractInOutSyncMessageReceiver.java:37)
      at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:408)
      at org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostReq
      uest(HTTPTransportUtils.java:288)
      at org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:1
      60)
      at org.apache.tuscany.binding.axis2.handler.WebServiceEntryPointServlet.
      doPost(WebServiceEntryPointServlet.java:235)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:763)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
      icationFilterChain.java:252)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
      ilterChain.java:173)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
      alve.java:213)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
      alve.java:178)
      at org.apache.tuscany.tomcat.TuscanyValve.invoke(TuscanyValve.java:87)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
      ava:126)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
      ava:105)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:869)

      at org.apache.tuscany.tomcat.integration.TomcatIntegrationTestCase.testW
      ebServiceIntegration(TomcatIntegrationTestCase.java:92)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at junit.framework.TestCase.runTest(TestCase.java:154)
      at junit.framework.TestCase.runBare(TestCase.java:127)
      at junit.framework.TestResult$1.protect(TestResult.java:106)
      at junit.framework.TestResult.runProtected(TestResult.java:124)
      at junit.framework.TestResult.run(TestResult.java:109)
      at junit.framework.TestCase.run(TestCase.java:118)
      at junit.framework.TestSuite.runTest(TestSuite.java:208)
      at junit.framework.TestSuite.run(TestSuite.java:203)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.maven.surefire.battery.JUnitBattery.executeJUnit(JUnitBatt
      ery.java:242)
      at org.apache.maven.surefire.battery.JUnitBattery.execute(JUnitBattery.j
      ava:216)
      at org.apache.maven.surefire.Surefire.executeBattery(Surefire.java:215)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:163)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:87)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.maven.surefire.SurefireBooter.runTestsInProcess(SurefireBo
      oter.java:313)
      at org.apache.maven.surefire.SurefireBooter.run(SurefireBooter.java:221)

      at org.apache.maven.test.SurefirePlugin.execute(SurefirePlugin.java:371)

      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPlugi
      nManager.java:412)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa
      ultLifecycleExecutor.java:534)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLi
      fecycle(DefaultLifecycleExecutor.java:475)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau
      ltLifecycleExecutor.java:454)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan
      dleFailures(DefaultLifecycleExecutor.java:306)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen
      ts(DefaultLifecycleExecutor.java:273)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
      fecycleExecutor.java:140)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:322)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:115)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:256)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)

      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: java.lang.IllegalArgumentException: wrong number of arguments
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.tuscany.container.java.invocation.AbstractJavaComponentInv
      oker.invokeTarget(AbstractJavaComponentInvoker.java:58)
      at org.apache.tuscany.container.java.invocation.AbstractJavaComponentInv
      oker.invoke(AbstractJavaComponentInvoker.java:67)
      at org.apache.tuscany.binding.axis2.builder.WebServiceEntryPointBuilder$
      EntryPointInvokerInterceptor.invoke(WebServiceEntryPointBuilder.java:160)
      at org.apache.tuscany.core.invocation.jdk.JDKInvocationHandler.invoke(JD
      KInvocationHandler.java:120)
      at org.apache.tuscany.binding.axis2.handler.WebServiceEntryPointInOutSyn
      cMessageReceiver.invokeBusinessLogic(WebServiceEntryPointInOutSyncMessageReceive
      r.java:88)
      ... 62 more
      </Exception></detail></soapenv:Fault...>
      at junit.framework.Assert.assertEquals(Assert.java:81)
      at junit.framework.Assert.assertEquals(Assert.java:87)
      at org.apache.tuscany.tomcat.integration.TomcatIntegrationTestCase.testW
      ebServiceIntegration(TomcatIntegrationTestCase.java:96)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at junit.framework.TestCase.runTest(TestCase.java:154)
      at junit.framework.TestCase.runBare(TestCase.java:127)
      at junit.framework.TestResult$1.protect(TestResult.java:106)
      at junit.framework.TestResult.runProtected(TestResult.java:124)
      at junit.framework.TestResult.run(TestResult.java:109)
      at junit.framework.TestCase.run(TestCase.java:118)
      at junit.framework.TestSuite.runTest(TestSuite.java:208)
      at junit.framework.TestSuite.run(TestSuite.java:203)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.maven.surefire.battery.JUnitBattery.executeJUnit(JUnitBatt
      ery.java:242)
      at org.apache.maven.surefire.battery.JUnitBattery.execute(JUnitBattery.j
      ava:216)
      at org.apache.maven.surefire.Surefire.executeBattery(Surefire.java:215)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:163)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:87)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.maven.surefire.SurefireBooter.runTestsInProcess(SurefireBo
      oter.java:313)
      at org.apache.maven.surefire.SurefireBooter.run(SurefireBooter.java:221)

      at org.apache.maven.test.SurefirePlugin.execute(SurefirePlugin.java:371)

      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPlugi
      nManager.java:412)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa
      ultLifecycleExecutor.java:534)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLi
      fecycle(DefaultLifecycleExecutor.java:475)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau
      ltLifecycleExecutor.java:454)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan
      dleFailures(DefaultLifecycleExecutor.java:306)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen
      ts(DefaultLifecycleExecutor.java:273)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
      fecycleExecutor.java:140)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:322)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:115)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:256)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)

      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)

      Apr 14, 2006 10:38:02 AM org.apache.catalina.core.StandardEngine start
      INFO: Starting Servlet Engine: Apache Tomcat/5.5.15
      Apr 14, 2006 10:38:02 AM org.apache.catalina.core.StandardHost start
      INFO: XML validation disabled
      Apr 14, 2006 10:38:02 AM org.apache.commons.modeler.modules.MbeansDescriptorsDOM
      Source execute
      INFO: Reading descriptors ( dom ) 10
      Apr 14, 2006 10:38:03 AM org.apache.catalina.startup.ContextConfig defaultWebCon
      fig
      INFO: No default web.xml
      [surefire] Running org.apache.tuscany.tomcat.integration.TomcatStandaloneTestCas
      e
      [surefire] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.653 sec
      [surefire]

      Results :
      [surefire] Tests run: 3, Failures: 1, Errors: 0

      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] There are test failures.
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 2 minutes 24 seconds
      [INFO] Finished at: Fri Apr 14 10:38:03 PDT 2006
      [INFO] Final Memory: 22M/43M
      [INFO] ------------------------------------------------------------------------

        Activity

        Jeremy Boynes added a comment -

        Closed at Raymond's request

        Raymond Feng added a comment -

        Please cancel this issue. I found out it's due to my env.


          People

          • Assignee:
            Unassigned
            Reporter:
            Raymond Feng
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development