Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.1.1
    • Component/s: Clustering
    • Labels:

      Description

      Make ICP compatible with IPv6.

        Issue Links

          Activity

          Alan M. Carroll created issue -
          Alan M. Carroll made changes -
          Field Original Value New Value
          Labels icp ipv6
          Alan M. Carroll made changes -
          Link This issue blocks TS-561 [ TS-561 ]
          Alan M. Carroll made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Leif Hedstrom added a comment -

          Alan: Even with ICP disabled, when I start up, I get

          [Oct 22 17:00:52.259] Server

          {0x7f02d58be800} WARNING: ICP interface [(null)] has no IP address
          [Oct 22 17:00:52.259] Server {0x7f02d58be800}

          WARNING: ICP interface has no IP address
          [Oct 22 17:00:52.259] Server

          {0x7f02d58be800} WARNING: ICP setup, no defined send Peer(s)
          [Oct 22 17:00:52.259] Server {0x7f02d58be800}

          WARNING: ICP setup, no defined send Peer(s)

          Leif Hedstrom added a comment -

          Also, trying to start traffic_manager gives

          [Oct 22 17:01:46.214] Manager

          {0x7fb82c87d800} FATAL: [LocalManager::initCCom] Unable to find IPv4 network interface lo. Exiting...
          [Oct 22 17:01:46.214] Manager {0x7fb82c87d800}

          FATAL: (last system error 2: No such file or directory)

          Leif Hedstrom made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Alan M. Carroll added a comment -

          ID10T error. Double bonus because I forgot that the regression tests don't detect problems in traffic_manager. Should be working now, I was able to replicate the problem and fix it locally.

          Alan M. Carroll made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Leif Hedstrom made changes -
          Fix Version/s 3.1.1 [ 12316496 ]
          Fix Version/s 3.1.2 [ 12317605 ]
          Leif Hedstrom made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          James Peach made changes -
          Link This issue relates to TS-32 [ TS-32 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          1d 13h 32m 1 Alan M. Carroll 22/Oct/11 04:45
          Resolved Resolved Reopened Reopened
          18h 14m 1 Leif Hedstrom 22/Oct/11 23:00
          Reopened Reopened Resolved Resolved
          1d 15h 6m 1 Alan M. Carroll 24/Oct/11 14:07
          Resolved Resolved Closed Closed
          229d 11h 28m 1 Leif Hedstrom 10/Jun/12 01:35

            People

            • Assignee:
              Alan M. Carroll
              Reporter:
              Alan M. Carroll
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development