Traffic Server
  1. Traffic Server
  2. TS-915

potential logical problem in net_io, especially for those whose buffer blocks exceed NET_MAX_IOV

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.1
    • Fix Version/s: 3.1.1
    • Component/s: Network
    • Labels:
      None

      Description

      think about this scenario, when read/write socket more than one time in every call read_net_io/write_to_net_io.

        Activity

        weijin created issue -
        weijin made changes -
        Field Original Value New Value
        Status Open [ 1 ] Patch Available [ 10002 ]
        weijin made changes -
        Attachment io_net.patch [ 12490211 ]
        Leif Hedstrom made changes -
        Fix Version/s 3.1.0 [ 12315515 ]
        Leif Hedstrom added a comment -

        Assigning to John for review.

        Leif Hedstrom made changes -
        Assignee John Plevyak [ jplevyak ]
        Leif Hedstrom made changes -
        Fix Version/s 3.1.1 [ 12316496 ]
        Fix Version/s 3.1.0 [ 12315515 ]
        Igor Galić added a comment -

        My critique regarding this patch is only formatting, as I have no idea what the problem is, or what the patch solves:

        This patch uses tabs instead of spaces, and at times a mix of both

        weijin made changes -
        Status Patch Available [ 10002 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        mohan_zl added a comment -

        Remember i have discussed with weijin, these functions have no problem, we can close this issue, and do nothing. Of course, these functions maybe contain some nonsense lines, like the codes processing "lock.m.m_ptr != s->vio.mutex.m_ptr".

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        21s 1 weijin 12/Aug/11 04:34
        Patch Available Patch Available Closed Closed
        7d 13h 7m 1 weijin 19/Aug/11 17:42

          People

          • Assignee:
            John Plevyak
            Reporter:
            weijin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development