Traffic Server
  1. Traffic Server
  2. TS-524

Have a single directive for HTTP ports

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: None
    • Component/s: Configuration
    • Labels:
      None
    • Environment:

      Any

      Description

      Why have both

      proxy.config.http.server_port

      and

      proxy.config.http.server_other_ports

      as config options? Unless there is a good reason to have to options, it would probably be better to have a single config option.

      See also https://issues.apache.org/jira/browse/TS-523

        Activity

        Leif Hedstrom added a comment -

        The main difference is, I think, that other_ports takes some descriptive information telling TS what it means. We'd have to merge that logic into the server_port as well if we merged this. I'm gonna move this to to v3.1, unless someone wants to work on this right now.

        Leif Hedstrom added a comment -

        I'm moving all 3.1.2 bugs out to 3.1.3, and we can move some 3.1.1 bugs out to 3.1.2, to get some release action going.

        Leif Hedstrom added a comment -

        Duplicate of TS-1077.


          People

          • Assignee:
            Unassigned
            Reporter:
            Marcus Clyne
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development