Traffic Server
  1. Traffic Server
  2. TS-448

Provide the ability to bind to more than one interface

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.1.0
    • Fix Version/s: None
    • Component/s: Network
    • Labels:
      None

      Description

      If I am running Traffic Server on a machine with multiple interfaces I would like to able to bind to a subset of those interfaces.

      I can bind to all or one using "proxy.local.incoming_ip_to_bind" but can't bind to more than one, but not all.

      It would also be useful to be able to specify different listening ports per interface.

        Activity

        Shaun McGinnity created issue -
        Gavin made changes -
        Field Original Value New Value
        Workflow jira [ 12520997 ] TS Workflow [ 12522728 ]
        Leif Hedstrom made changes -
        Fix Version/s 2.3.0 [ 12314777 ]
        Leif Hedstrom made changes -
        Fix Version/s 3.1 [ 12315515 ]
        Fix Version/s 2.3.0 [ 12314777 ]
        Leif Hedstrom made changes -
        Fix Version/s 2.1.5 [ 12315491 ]
        Fix Version/s 3.1 [ 12315515 ]
        Leif Hedstrom made changes -
        Fix Version/s 2.1.6 [ 12315574 ]
        Fix Version/s 2.1.5 [ 12315491 ]
        Leif Hedstrom added a comment -

        Moving these to v3.1 (next dev release after v3.0), please reassign if you will work on this for v2.1.6 / v3.0.

        Leif Hedstrom made changes -
        Fix Version/s 3.1 [ 12315515 ]
        Fix Version/s 2.1.6 [ 12315574 ]
        Leif Hedstrom made changes -
        Fix Version/s 3.1.1 [ 12316496 ]
        Fix Version/s 3.1.0 [ 12315515 ]
        Leif Hedstrom added a comment -

        Moving these to 3.1.2 for now. please move back if they will be worked on asap for 3.1.1.

        Leif Hedstrom made changes -
        Fix Version/s 3.1.2 [ 12317605 ]
        Fix Version/s 3.1.1 [ 12316496 ]
        Leif Hedstrom made changes -
        Fix Version/s 3.1.3 [ 12317969 ]
        Fix Version/s 3.1.2 [ 12317605 ]
        Leif Hedstrom made changes -
        Fix Version/s 3.1.3 [ 12317969 ]
        Leif Hedstrom added a comment -

        Marking as duplicate of TS-1077.

        Leif Hedstrom made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Leif Hedstrom made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        492d 10h 40m 1 Leif Hedstrom 26/Jan/12 00:20
        Resolved Resolved Closed Closed
        136d 1h 15m 1 Leif Hedstrom 10/Jun/12 02:36

          People

          • Assignee:
            Unassigned
            Reporter:
            Shaun McGinnity
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development