Uploaded image for project: 'Traffic Server'
  1. Traffic Server
  2. TS-399

./configure not honoring --*dir options properly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.1
    • Fix Version/s: 2.1.2
    • Component/s: Build
    • Labels:
      None

      Description

      I'm having problems with out generated 'configure', and various --*dir options. For example, this does not produce what I'd expect it to do:

      ./configure --prefix=/opt/ats --sysconfdir=/opt/ats/conf

      I'd expect the above to put my "config" files into /opt/ats/conf, but they end up in /opt/ats/etc/trafficserver instead. I'm pretty sure this is not as intended, because at runtime, the above installation will fail. E.g.

      root@loki 528/0 # ./bin/traffic_server
      [TrafficServer] using root directory '/opt/ats'
      unable to access() management path '/opt/ats/conf': 2, No such file or directory
      please set management path via command line '-d <managment directory>'

        Attachments

        1. ts-399.diff
          4 kB
          Theo Schlossnagle

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              zwoop Leif Hedstrom
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: