Traffic Server
  1. Traffic Server
  2. TS-370

If you use --enable-debug, the regression tests crash.

    Details

      Description

      If you use the --enable-debug option on configure and then run the -R 1 regression tests, it will crash early in the testing with a seg fault.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        36d 17h 12m 1 Leif Hedstrom 30/Jun/10 17:45
        Resolved Resolved Closed Closed
        55d 10h 7m 1 Leif Hedstrom 25/Aug/10 03:53
        Gavin made changes -
        Workflow jira [ 12511682 ] TS Workflow [ 12522357 ]
        Leif Hedstrom made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Leif Hedstrom made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Leif Hedstrom added a comment -

        I think this is fixed, at least I'm not able to reproduce this any more. Please reopen if this is still an issue.

        Alan M. Carroll made changes -
        Field Original Value New Value
        Attachment ts-370-patch-trunk.txt [ 12445401 ]
        Alan M. Carroll added a comment -

        Fix for this crash and for the crash in Cache testing that happens without --enable-debug.

        Issues:

        • The int argument versions of r_sequential and r_parallel were not called, the pure variadic forms were always preferred.
        • NULL is a 32 bit value for varargs. If the number of variadic arguments passed was more than could fit in CPU registers, the wrong sized 0 would be stored in the overflow area, leading to bad pointers being stored. A new NULL_PTR define was added to avoid this problem.
        Alan M. Carroll created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Alan M. Carroll
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development