Traffic Server
  1. Traffic Server
  2. TS-327

traffic_manager silently fails to start if proxy.config.cluster.ethernet_interface is incorrect

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.0a
    • Fix Version/s: 2.1.3
    • Component/s: Configuration
    • Labels:
      None
    • Environment:

      ubuntu 10.04 (rc) 64 bit

      Description

      First ever build from source, http://incubator.apache.org/trafficserver/docs/v2/admin/getstart.htm advises me to do
      ./trafficserver start
      to start things up.. it failed silently.

      Nothing interesting in any of the logs. (nothing at all really, other than messages about "opening logs").

      Turns out only traffic_cop was running, not traffic_manager or traffic_server

      Debugger on traffic manager had it exiting "Unable to find network interface eth0.".. which is true enough - I use "br0" for most things.

      Traffic manager noted the problem at level "note" and then did a full exit.

      A full exit should be at least level Error so I could correct the problem.

        Activity

        Hide
        patrick mcmanus added a comment -

        /home/mcmanus/src/trafficserver/local/traffic/branches/2.0.x>svn diff
        Index: proxy/mgmt2/LocalManager.cc
        ===================================================================
        — proxy/mgmt2/LocalManager.cc (revision 936022)
        +++ proxy/mgmt2/LocalManager.cc (working copy)
        @@ -436,7 +436,7 @@

        found = mgmt_getAddrForIntr(intrName, &cluster_addr);
        if (found == false)

        { - mgmt_log(stderr, "[LocalManager::initCCom] Unable to find network interface %s. Exiting...\n", intrName); + mgmt_elog(stderr, "[LocalManager::initCCom] Unable to find network interface %s. Exiting...\n", intrName); _exit(1); }
        Show
        patrick mcmanus added a comment - /home/mcmanus/src/trafficserver/local/traffic/branches/2.0.x>svn diff Index: proxy/mgmt2/LocalManager.cc =================================================================== — proxy/mgmt2/LocalManager.cc (revision 936022) +++ proxy/mgmt2/LocalManager.cc (working copy) @@ -436,7 +436,7 @@ found = mgmt_getAddrForIntr(intrName, &cluster_addr); if (found == false) { - mgmt_log(stderr, "[LocalManager::initCCom] Unable to find network interface %s. Exiting...\n", intrName); + mgmt_elog(stderr, "[LocalManager::initCCom] Unable to find network interface %s. Exiting...\n", intrName); _exit(1); }
        Hide
        Manish Pandey added a comment -

        I use a machine with two ethernet ports, where eth1 is in use, and eth0 is disconnected. The default records.config setting, eth0, for proxy.config.cluster.ethernet_interface does not work and traffic_manager fails silently.

        Show
        Manish Pandey added a comment - I use a machine with two ethernet ports, where eth1 is in use, and eth0 is disconnected. The default records.config setting, eth0, for proxy.config.cluster.ethernet_interface does not work and traffic_manager fails silently.
        Hide
        Leif Hedstrom added a comment -

        There should now at least be a better / informative error in /var/log/messages (or whatever your syslog is configured to log to).

        Show
        Leif Hedstrom added a comment - There should now at least be a better / informative error in /var/log/messages (or whatever your syslog is configured to log to).

          People

          • Assignee:
            Leif Hedstrom
            Reporter:
            patrick mcmanus
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development