ink_sock.cc and SocketManager.cc both have random assortment of simple wrappers around socket and file descriptor APIs. Its confusing for them to be split across 2 locations and in some places, we don't even use the wrapper.
We should kill SocketManager and use ink_sock exclusively. We should use a consistent naming convention (ie. we don't need both safe_bind and ink_bind). We should use the wrappers everywhere across the code base (or remove the wrapper if it makes sense).