Uploaded image for project: 'Traffic Server'
  1. Traffic Server
  2. TS-1656

3.2.x - enable_read_while_writer not working in 3.2.0

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 3.2.0
    • 3.2.4
    • Cache
    • None
    • Ubuntu 10.04

    Description

      enable_read_while_writer is not currently working as it should

      with the settings
      CONFIG proxy.config.cache.enable_read_while_writer INT 1
      CONFIG proxy.config.cache.max_doc_size INT 0
      CONFIG proxy.config.http.background_fill_active_timeout INT 0
      CONFIG proxy.config.http.background_fill_completed_threshold FLOAT 0

      If I do
      wget http://127.0.0.1:8080/largefile.mpg g -O /dev/null
      and then on the same box 30 seconds later (while the first one is still going I do)
      wget http://127.0.0.1:8080/largefile.mpg g -O /dev/null
      again

      The master server (after I kill them both) gets

      012-09-03T10:49:32.007667+09:18 master1-adl6 nginx: 1.1.1.1 - - [03/Sep/2012:10:49:32 +0930] "GET /largefile.mpg HTTP/1.1" 200 306253448 "" "Wget/1.12 (linux-gnu)" ""
      2012-09-03T10:49:32.879914+09:18 master1-adl6 nginx: 1.1.1.1 - - [03/Sep/2012:10:49:32 +0930] "GET /largefile.mpg HTTP/1.1" 200 226717704 "" "Wget/1.12 (linux-gnu)" ""

      Attachments

        Issue Links

          Activity

            People

              weijin Wei Jin
              punkley Kingsley Foreman
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: