MyFaces Trinidad
  1. MyFaces Trinidad
  2. TRINIDAD-909

lightweight dialog/modal panelPopup - skinnable blocked area

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.5-core, 1.2.5-core
    • Fix Version/s: 1.0.8-core, 1.2.8-core
    • Component/s: Skinning
    • Labels:
      None

      Description

      the area outside a lightweight dialog (or modal panelPopup) is blocked (it's a transparent div + cursor: not-allowed which covers the whole page)
      this new skinning selector allows the styling of the blocked area.

      e.g.:
      af|dialog::blocked-area{
      background-color: black !important;
      filter: Alpha(opacity: 60) !important;
      -moz-opacity: 0.6;
      }

      1. skinning_blocked_area_beta.patch
        7 kB
        Gerhard Petracek
      2. skinning_blocked_area.patch
        5 kB
        Gerhard Petracek

        Issue Links

          Activity

          Gerhard Petracek created issue -
          Gerhard Petracek made changes -
          Field Original Value New Value
          Status Open [ 1 ] Patch Available [ 10002 ]
          Gerhard Petracek added a comment -

          this patch is a first draft for: implementation and naming
          + a basis for the final solution
          todo - e.g.:
          improve the coverage of the blocked area (onresize and onscroll)
          however, that's a separate issue - also the current implementation doesn't block the whole page

          Gerhard Petracek made changes -
          Attachment skinning_blocked_area_beta.patch [ 12373632 ]
          Gerhard Petracek made changes -
          Link This issue is blocked by TRINIDAD-910 [ TRINIDAD-910 ]
          Gerhard Petracek made changes -
          Attachment skinning_blocked_area.patch [ 12378067 ]
          Gerhard Petracek added a comment -

          the committed patch: skinning_blocked_area.patch
          difference: recalculation of the blocking div isn't patched

          Gerhard Petracek made changes -
          Resolution Fixed [ 1 ]
          Fix Version/s  1.0.8-core [ 12313040 ]
          Fix Version/s  1.2.8-core [ 12313041 ]
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Cristiano added a comment -

          I've applied with success this styling on the blocked area in my CSS (i use the Trinidad framework 1.2.8) and it's OK with Firefox, Safari, IE6, but it fails on IE7. It seems that IE7 ignores completely the "af|dialog::blocked-area"...every style that i write inside this CSS block does noy applied.
          I've tried a lot of workarounds witout success...someone can help me please??
          Thanks a lot.

          Cristiano

          Gerhard Petracek added a comment -

          solution for ie 7:

          e.g.:
          af|dialog::blocked-area

          { background-color: black !important; filter: Alpha(opacity: 60) !important; }
          Gerhard Petracek made changes -
          Description the area outside a lightweight dialog (or modal panelPopup) is blocked (it's a transparent div + cursor: not-allowed which covers the whole page)
          this new skinning selector allows the styling of the blocked area.

          e.g.:
          af|dialog::blocked-area{
              background-color: black !important;
              filter: Alpha(opacity: 60);
              -moz-opacity: 0.6;
          }
          the area outside a lightweight dialog (or modal panelPopup) is blocked (it's a transparent div + cursor: not-allowed which covers the whole page)
          this new skinning selector allows the styling of the blocked area.

          e.g.:
          af|dialog::blocked-area{
              background-color: black !important;
              filter: Alpha(opacity: 60) !important;
              -moz-opacity: 0.6;
          }
          Gerhard Petracek made changes -
          Comment [ the problem is caused by the workaround for ie 7

          within the patch file:
          ...
          + TrPanelPopup._mask.className = page.getStyleClass("af|dialog::blocked-area");
          +
               var cssText = "display:none;position: absolute; z-index: 5000;top: 0px;left: 0px;cursor: not-allowed;";
               if (_agent.isIE && _agent.version == 7)
                 //workaround for bug in IE7 : see http://blog.thinkature.com/index.php/2006/12/29/odd-mouse-handling-with-transparent-objects-under-internet-explorer-7/
          @@ -356,23 +364,31 @@
          ...

          it works after removing it ]
          Matthias Weßendorf made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          7s 1 Gerhard Petracek 20/Jan/08 19:21
          Patch Available Patch Available Resolved Resolved
          57d 49m 1 Gerhard Petracek 17/Mar/08 20:11
          Resolved Resolved Closed Closed
          680d 12h 33m 1 Matthias Weßendorf 27/Jan/10 08:45

            People

            • Assignee:
              Gerhard Petracek
              Reporter:
              Gerhard Petracek
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development