Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 2.0.2-core
    • Fix Version/s: None
    • Component/s: Skinning
    • Labels:
      None

      Description

      In cases where skins specify overlapping version ranges, skin pregeneration may fail to generate certain style sheets.

      For example, imagine the skin specifies @agent rules for the following version ranges:

      1. min-version:1
      2. max:version:3
      3. min-version:8

      With our current implementation, we only attempt to generate style sheets for the start and end of each version range.

      For the above example, this would be:

      • 0 (start of #2)
      • 1 (start of #1
      • 3 (end of #2)
      • 8 (start of #3)
      • Integer.MAX_VALUE (end of #1 and #3)

      If the actual agent version is 7, we should use a style sheet that matches #1, but not #2 or #3. However, we since we only use the start/end points of each version range to determine which style sheets to pregenerate, we fail to pregenerate such a style sheet.

      1. trinidad-2250.patch
        11 kB
        Andy Schwartz
      2. trinidad-2250-take2.patch
        12 kB
        Andy Schwartz

        Activity

        Andy Schwartz created issue -
        Andy Schwartz made changes -
        Field Original Value New Value
        Attachment trinidad-2250.patch [ 12519643 ]
        Andy Schwartz made changes -
        Attachment trinidad-2250-take2.patch [ 12519681 ]
        Andy Schwartz made changes -
        Attachment trinidad-2250-take2.patch [ 12519681 ]
        Andy Schwartz made changes -
        Attachment trinidad-2250-take2.patch [ 12519683 ]

          People

          • Assignee:
            Andy Schwartz
            Reporter:
            Andy Schwartz
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:

              Development