MyFaces Trinidad
  1. MyFaces Trinidad
  2. TRINIDAD-2218

Need an ability for the WindowManager implementation to be executed before all Configurators and filters and to complete teh response

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.2-core
    • Fix Version/s: 2.0.2-core
    • Component/s: None
    • Labels:
      None

      Description

      Since WindowManager is expected to make the Window Map available to all Configurators, we need a way to ensure that it is executed before all Configurators and filters. Also, WindowManager needs to be able to complete a response, so that it can send a script response to the client.

        Activity

        Max Starets added a comment -

        Hey Scott, thanks for reviewing the patch. Configurator.disableConfiguratorServices() did not work because we weren't releasing the RequestContext at the end.
        When you say 'Trinidad filter', do you mean TrinidadFilterImpl? The issue is that RequestContext is not available there. If you mean filters invoked after Configurators, then it won't work either because we need to provide a window Id to configurators.
        Lets discuss this offline

        Scott O'Bryan added a comment -

        If I read this correctly, this adds the ability to disable the configurator system if the WindowManager states that the request needs to be aborted. Is there a reason that the disabling code does not use Configurator.disableConfiguratorServices() http://myfaces.apache.org/trinidad/trinidad-api/apidocs/org/apache/myfaces/trinidad/config/Configurator.html#disableConfiguratorServices%28javax.servlet.ServletRequest%29. It seems to me that the Trinidad filter might be a more ideal place to handle this to ensure this logic since Configurators cannot prevent execution of the faces lifecycle. Additionally it limits the exposure to portlet environments as the code will not get executed.


          People

          • Assignee:
            Max Starets
            Reporter:
            Max Starets
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development