Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Invalid
    • Affects Version/s: 1.0.0-incubating-core
    • Fix Version/s: 1.0.0-incubating-core
    • Component/s: None
    • Labels:
      None

      Description

      The showRequired attribute is currently broken as implemented in trunk. I noticed it on components base on the class
      org.apache.myfaces.trinidadinternal.renderkit.core.xhtml.LabelAndMessageRenderer

      1st issue is the labelShowRequired() method ORing || both the required and showRequired flag making the second one useless in case required is true. I would recommend changing the conditional to && and setting the default value for showRequired to true.

        Activity

        Stefan Podkowinski created issue -
        Adam Winer added a comment -

        The purpose of showRequired is not to turn off display of the required icon, it's to turn it on for fields that aren't strictly required. What you're recommending would break that. You can use skinning to remove required icons in general. If you're looking for a way to turn it off for a field that is required on a per-instance basis, then that would be an enhancement request, not a bug.

        Adam Winer made changes -
        Field Original Value New Value
        Resolution Invalid [ 6 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Matthias Weßendorf made changes -
        Affects Version/s 1.0.0-incubating-core [ 12312336 ]
        Fix Version/s 1.0.0-incubating-core [ 12312336 ]
        Matthias Weßendorf made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Jeff Turner made changes -
        Fix Version/s 1.0.0-incubating-core [ 12312336 ]
        Affects Version/s 1.0.0-incubating-core [ 12312336 ]
        Project MyFaces ADF-Faces [ 12310300 ] MyFaces Trinidad [ 12310661 ]
        Key ADFFACES-252 TRINIDAD-165
        Jeff Turner made changes -
        Fix Version/s 1.0.0-incubating-core [ 12312492 ]
        Affects Version/s 1.0.0-incubating-core [ 12312492 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        2d 18h 25m 1 Adam Winer 27/Oct/06 03:13
        Resolved Resolved Closed Closed
        140d 6h 3m 1 Matthias Weßendorf 16/Mar/07 08:16

          People

          • Assignee:
            Unassigned
            Reporter:
            Stefan Podkowinski
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development