MyFaces Trinidad
  1. MyFaces Trinidad
  2. TRINIDAD-1166

Wrong skin selectors for selectOneRadio component

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.8-core
    • Fix Version/s: 1.2.10-core, 1.0.10-core
    • Component/s: Skinning
    • Labels:
      None

      Description

      Renderer for selectOneRadio component using wrong names for component state icons (read-only and disabled). It uses af|selectBooleanCheckbox::disabled-selected-icon instead of af|selectOneRadio::disabled-selected-icon etc.

        Activity

        Matthias Weßendorf added a comment -

        since there was no fix... we remove the fix version....

        Jeanne Waldman added a comment -

        I think the problem is selectBooleanRadio uses the wrong names. selectOneRadio does not have disabled or read-only icons.

        Jeanne Waldman added a comment -

        fixed the error in the constants. e.g.,
        public static final String AF_SELECT_BOOLEAN_RADIO_DISABLED_SELECTED_ICON_NAME =

        • "af|selectBooleanCheckbox::disabled-selected-icon";
          + "af|selectBooleanRadio::disabled-selected-icon";

          People

          • Assignee:
            Jeanne Waldman
            Reporter:
            Tomas Havelka
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development