MyFaces Trinidad
  1. MyFaces Trinidad
  2. TRINIDAD-1086

Tree's RowKeySet.isContained NullPointerException when running demo.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.7-core
    • Fix Version/s: 1.2.10-core
    • Component/s: Components
    • Labels:
      None

      Description

      I see this error occasionally, so it might be hard to reproduce.

      I run the demo index.jspx page. Then I click on some link, like Component Demos,
      and I get this error:

      500 Internal Server Error

      java.lang.NullPointerException
      at org.apache.myfaces.trinidad.model.RowKeySet.isContained(RowKeySet.java:104)
      at org.apache.myfaces.trinidad.component.HierarchyUtils.__iterateOverTree(HierarchyUtils.java:155)
      at org.apache.myfaces.trinidad.component.UIXTree.processFacetsAndChildren(UIXTree.java:272)
      at org.apache.myfaces.trinidad.component.UIXCollection.decodeChildrenImpl(UIXCollection.java:196)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildren(UIXComponentBase.java:955)
      at org.apache.myfaces.trinidad.component.UIXCollection.processDecodes(UIXCollection.java:190)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildrenImpl(UIXComponentBase.java:969)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildren(UIXComponentBase.java:955)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.processDecodes(UIXComponentBase.java:811)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildrenImpl(UIXComponentBase.java:969)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildren(UIXComponentBase.java:955)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.processDecodes(UIXComponentBase.java:811)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildrenImpl(UIXComponentBase.java:969)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildren(UIXComponentBase.java:955)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.processDecodes(UIXComponentBase.java:811)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildrenImpl(UIXComponentBase.java:969)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildren(UIXComponentBase.java:955)
      at org.apache.myfaces.trinidad.component.UIXForm.processDecodes(UIXForm.java:75)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildrenImpl(UIXComponentBase.java:969)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.decodeChildren(UIXComponentBase.java:955)
      at org.apache.myfaces.trinidad.component.UIXComponentBase.processDecodes(UIXComponentBase.java:811)
      at javax.faces.component.UIComponentBase.processDecodes(UIComponentBase.java:1015)
      at javax.faces.component.UIViewRoot.processDecodes(UIViewRoot.java:504)
      at com.sun.faces.lifecycle.ApplyRequestValuesPhase.execute(ApplyRequestValuesPhase.java:78)
      at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:100)
      at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:265)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:64)
      at org.apache.myfaces.trinidadinternal.webapp.TrinidadFilterImpl._invokeDoFilter(TrinidadFilterImpl.java:238)
      at org.apache.myfaces.trinidadinternal.webapp.TrinidadFilterImpl._doFilterImpl(TrinidadFilterImpl.java:195)
      at org.apache.myfaces.trinidadinternal.webapp.TrinidadFilterImpl.doFilter(TrinidadFilterImpl.java:138)
      at org.apache.myfaces.trinidad.webapp.TrinidadFilter.doFilter(TrinidadFilter.java:92)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:15)
      at org.apache.myfaces.trinidaddemo.webapp.RedirectFilter.doFilter(RedirectFilter.java:97)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:600)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:351)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.HttpRequestHandler.doDispatchRequest(HttpRequestHandler.java:977)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:878)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:676)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:644)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.HttpRequestHandler.serveOneRequest(HttpRequestHandler.java:436)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.HttpRequestHandler.run(HttpRequestHandler.java:185)
      at com.evermind[Oracle Containers for J2EE 11g (11.1.1.0.0) ].server.http.HttpRequestHandler.run(HttpRequestHandler.java:153)
      at oracle.oc4j.network.ServerSocketReadHandler$ClientRunnable.run(ServerSocketReadHandler.java:276)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)

      It goes away when I refresh the page, and doesn't come back.

        Activity

        Andrew Robinson added a comment -

        I have been unable to reproduce the problem with a simple test case, so I don't have enough information to log a Mojarra / RI bug. Guess the "fix" of renaming the bean I made will have to do for now.

        Andrew Robinson added a comment -

        When a managed-bean has name 'tree' and has a managed reference, things stop working with the RI. I changed the bean 'tree' to 'demoTree' as a work-around. I will try to reproduce it with a test case and open an RI bug.

        Andrew Robinson added a comment -

        This only happens if the JSF RI is used, it works fine with myfaces 1.2.3, still researching.

        Andrew Robinson added a comment -

        Note that it seems to work fine in jetty, but fails with WLS when import into the project using the trinidad-demo.war

        Andrew Robinson added a comment -

        I can reproduce this on the latest 1.2.9.1. I am looking into it.

        Jeanne Waldman added a comment -

        This could be a caching problem. I'll try to clear my cache before and I'll post the results.


          People

          • Assignee:
            Andrew Robinson
            Reporter:
            Jeanne Waldman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development