Torque
  1. Torque
  2. TORQUE-125

Maven2 Plugin fails on local M2 repo containing spaces

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.3
    • Fix Version/s: 4.0-beta1
    • Component/s: Maven 2 Plugin
    • Labels:
      None
    • Environment:
      Maven version: 2.0.9
      Java version: 1.6.0_07
      OS name: "windows xp" version: "5.1" arch: "x86" Family: "windows"

      Description

      When invoking the plugin I get the following error (see below) - it does not like the spaces in "C:/Dokumente und Einstellungen/goeschl/". When moving the local repo to a properly named location everything works

      === START OF STDOUT ===
      Downloading: http://repo1.maven.org/maven2/hsqldb/hsqldb/1.8.0.7/hsqldb-1.8.0.7.jar
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] null
      Illegal character in path at index 18: file:/C:/Dokumente und Einstellungen/goeschl/.m2/repository/org/apache/ant/ant/1.7.0/ant-1.7.0.jar
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.IllegalArgumentException
      at java.net.URI.create(URI.java:842)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.tools.ant.launch.Locator.fromURI(Locator.java:162)
      at org.apache.tools.ant.launch.Locator.getResourceSource(Locator.java:119)
      at org.apache.tools.ant.launch.Locator.getClassSource(Locator.java:90)
      at org.apache.tools.ant.Project.setAntLib(Project.java:313)
      at org.apache.tools.ant.Project.initProperties(Project.java:309)
      at org.apache.tools.ant.Project.init(Project.java:295)
      at org.apache.torque.mojo.TexenTaskMojo.setGeneratorTask(TexenTaskMojo.java:126)
      at org.apache.torque.mojo.TexenTaskMojo.<init>(TexenTaskMojo.java:109)
      at org.apache.torque.mojo.DataModelTaskMojo.<init>(DataModelTaskMojo.java:111)
      at org.apache.torque.mojo.OMMojo.<init>(OMMojo.java:461)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      at java.lang.Class.newInstance0(Class.java:355)
      at java.lang.Class.newInstance(Class.java:308)
      at org.codehaus.plexus.component.factory.java.JavaComponentFactory.newInstance(JavaComponentFactory.java:44)
      at org.codehaus.plexus.DefaultPlexusContainer.createComponentInstance(DefaultPlexusContainer.java:1464)
      at org.codehaus.plexus.component.manager.AbstractComponentManager.createComponentInstance(AbstractComponentManager.java:93)
      at org.codehaus.plexus.component.manager.PerLookupComponentManager.getComponent(PerLookupComponentManager.java:48)
      at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:331)
      at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:440)
      at org.apache.maven.plugin.DefaultPluginManager.getConfiguredMojo(DefaultPluginManager.java:609)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:429)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:558)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:499)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:478)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:330)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:291)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:142)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:287)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: java.net.URISyntaxException: Illegal character in path at index 18: file:/C:/Dokumente und Einstellungen/goeschl/.m2/repository/org/apache/ant/ant/1.7.0/ant-1.7.0.jar
      at java.net.URI$Parser.fail(URI.java:2809)
      at java.net.URI$Parser.checkChars(URI.java:2982)
      at java.net.URI$Parser.parseHierarchical(URI.java:3066)
      at java.net.URI$Parser.parse(URI.java:3014)
      at java.net.URI.<init>(URI.java:578)
      at java.net.URI.create(URI.java:840)
      ... 45 more
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 9 seconds
      [INFO] Finished at: Fri Nov 06 14:39:33 CET 2009
      [INFO] Final Memory: 8M/16M
      [INFO] ------------------------------------------------------------------------

      === END OF STDOUT ===

        Activity

        Thomas Vandahl added a comment -

        I remember seing this before elsewhere. However the stacktrace shows this exception to be in the ANT code. I just verified that no repository-related information is handled by the TexenTaskMojo.

        Siegfried Goeschl added a comment -

        Maybe the path should/could be escaped - basically it breaks the plugin on many german Windows installation

        Thomas Vandahl added a comment -

        I'd love to agree, just that no path is handled by our code...

        I'm sorry I don't know what we could do here.

        Thomas Fox added a comment -

        I tried to reproduce this using maven 2.2.1 on Win XP with the repository path F:\java\maven\local repo . The Torque 4 test project runs fine, so though I do not know what the problem was, this seems to have been fixed in the meantime


          People

          • Assignee:
            Thomas Fox
            Reporter:
            Siegfried Goeschl
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development