TomEE
  1. TomEE
  2. TOMEE-34

seam-remoting-helloworld fails to deploy

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0-beta-1
    • Fix Version/s: 1.0.0-beta-2
    • Component/s: None
    • Labels:
      None
    • Environment:
      Seam 3.1.1 SNAPSHOT

      Description

      See the attached application and stack trace for details.

      1. remoting.txt
        5 kB
        Jozef Hartinger
      2. remoting-helloworld.war
        1.09 MB
        Jozef Hartinger

        Issue Links

          Activity

          Jozef Hartinger created issue -
          Jozef Hartinger made changes -
          Field Original Value New Value
          Attachment remoting-helloworld.war [ 12498742 ]
          Jozef Hartinger made changes -
          Attachment remoting.txt [ 12498743 ]
          Romain Manni-Bucau made changes -
          Comment [ it deploys on the 1.0.0-beta-2-SNAPSHOT, can you try the snaphost from https://repository.apache.org/content/groups/snapshots/org/apache/openejb/apache-tomee/1.0.0-beta-2-SNAPSHOT/ ]
          Romain Manni-Bucau added a comment -

          here the exception:

          Caused by: java.lang.RuntimeException: javax.enterprise.inject.UnsatisfiedResolutionException: Api type [javax.enterprise.inject.spi.BeanManager] is not found with the qualifiers
          Qualifiers: [@javax.enterprise.inject.Default()]
          for injection into Method Injection Point, method name : beforeBeanDiscovery, Bean Owner : [XmlConfigExtension, Name:null, WebBeans Type:EXTENSION, API Types:[org.jboss.solder.config.xml.bootstrap.XmlConfigExtension,javax.enterprise.inject.spi.Extension,java.lang.Object], Qualifiers:[javax.enterprise.inject.Default]]
          at org.apache.openejb.cdi.OpenEJBLifecycle.startApplication(OpenEJBLifecycle.java:317)
          at org.apache.openejb.cdi.ThreadSingletonServiceImpl.initialize(ThreadSingletonServiceImpl.java:95)
          ... 39 more
          Caused by: javax.enterprise.inject.UnsatisfiedResolutionException: Api type [javax.enterprise.inject.spi.BeanManager] is not found with the qualifiers
          Qualifiers: [@javax.enterprise.inject.Default()]
          for injection into Method Injection Point, method name : beforeBeanDiscovery, Bean Owner : [XmlConfigExtension, Name:null, WebBeans Type:EXTENSION, API Types:[org.jboss.solder.config.xml.bootstrap.XmlConfigExtension,javax.enterprise.inject.spi.Extension,java.lang.Object], Qualifiers:[javax.enterprise.inject.Default]]
          at org.apache.webbeans.util.InjectionExceptionUtils.throwUnsatisfiedResolutionException(InjectionExceptionUtils.java:92)
          at org.apache.webbeans.container.ResolutionUtil.checkResolvedBeans(ResolutionUtil.java:98)
          at org.apache.webbeans.container.InjectionResolver.getInjectionPointBean(InjectionResolver.java:265)
          at org.apache.webbeans.event.ObserverMethodImpl.getMethodArguments(ObserverMethodImpl.java:387)
          at org.apache.webbeans.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:203)
          at org.apache.webbeans.event.NotificationManager.fireEvent(NotificationManager.java:461)
          at org.apache.webbeans.container.BeanManagerImpl.fireEvent(BeanManagerImpl.java:473)
          at org.apache.openejb.cdi.BeansDeployer.fireBeforeBeanDiscoveryEvent(BeansDeployer.java:146)
          at org.apache.openejb.cdi.OpenEJBLifecycle.startApplication(OpenEJBLifecycle.java:200)
          ... 40 more

          Romain Manni-Bucau made changes -
          Link This issue is blocked by OWB-622 [ OWB-622 ]
          Romain Manni-Bucau made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Romain Manni-Bucau [ romain.manni-bucau ]
          Fix Version/s 1.0.0-beta-2 [ 12318446 ]
          Resolution Fixed [ 1 ]
          Jozef Hartinger added a comment -

          Is there a snapshot build I could verify on?

          Romain Manni-Bucau added a comment -

          yes, here https://repository.apache.org/content/groups/snapshots/org/apache/openejb/apache-tomee/1.0.0-beta-2-SNAPSHOT/ i think it is not the exact trunk but it is close to it. Just take care to take the last one

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          5d 4h 9m 1 Romain Manni-Bucau 17/Oct/11 18:07

            People

            • Assignee:
              Romain Manni-Bucau
              Reporter:
              Jozef Hartinger
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development