MyFaces Tomahawk
  1. MyFaces Tomahawk
  2. TOMAHAWK-42

ImportCalendar doesn't work in FireFox browser

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1.5
    • Component/s: Calendar
    • Labels:
      None
    • Environment:
      Windows XP with FireFox browser

      Description

      InputCalendar component (tomahawk extensions) is working fine in Internet Explorer but it doesn't work in FireFox browser. The following is javascript error message detected by FireFox browser. I can see the calendar image on FireFox browser but the calendar doesn't pop up when I click the calendar image.

      Code in JSP:
      <t:inputCalendar id="personDOBInput" title="#

      {uimsg['label.person.DOB']}

      " alt="date"
      forceId="true" size="13" value="#

      {person.dateOfBirth}

      "
      popupDateFormat="#

      {uimsg['format.date']}

      "
      required="true" validator="#

      {memberController.validate}

      "
      renderAsPopup="true" renderPopupButtonAsImage="true"/>

      Error: jscalendarSetImageDirectory is not defined
      Source File: http://localhost/CAS/jsp/provider/presumptiveEligibility/providerSearch.jsf

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        205d 2h 47m 1 Matthias Weßendorf 06/Jul/06 08:30
        Manfred Geiler made changes -
        Fix Version/s 1.1.5 [ 12312397 ]
        Fix Version/s 1.1.5-SNAPSHOT [ 12311959 ]
        Matthias Weßendorf made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Fix Version/s 1.1.5-SNAPSHOT [ 12311959 ]
        Mike Youngstrom added a comment -

        Ya, I think this can be closed. One note though. If you're page is set as xhtml then firefix 1.5 will throw an exception because document.write() is not a supported operation in xhtml. To solve that problem make sure your content type is plain html. I don't know if that is the problem the original poster was having or not so this might also be a duplicate of the document.write bug related to inputCalendar not sure of the bug number right off hand.

        Mike

        Holger Schimanski added a comment -

        I can confirm, that inputCalendar from http://www.irian.at/myfaces/calendar.jsf is working fine in Firefox 1.5 on Windows XP and MacOS X.

        Holger

        Matthias Weßendorf added a comment -

        Hey Mike,

        so we can close this issue ?

        Mike Youngstrom added a comment -

        I can confirm that a simple example (<t:inputCalendar renderAsPopup="true"/>) was not working in 1.1.1 but is now working in 1.1.3.

        Mike

        sean schofield made changes -
        Workflow  MyFaces Workflow [ 12358478 ] MyFaces Workflow2 [ 12360898 ]
        sean schofield made changes -
        Workflow  MyFaces Workflow [ 12356866 ] MyFaces Workflow2 [ 12358478 ]
        sean schofield made changes -
        Workflow MyFaces Workflow2 [ 12356325 ]  MyFaces Workflow [ 12356866 ]
        sean schofield made changes -
        Workflow MyFaces Workflow [ 12354319 ] MyFaces Workflow2 [ 12356325 ]
        sean schofield made changes -
        Workflow MyFaces Workflow2 [ 12348851 ] MyFaces Workflow [ 12354319 ]
        sean schofield made changes -
        Workflow MyFaces Workflow [ 12347509 ] MyFaces Workflow2 [ 12348851 ]
        Matthias Weßendorf made changes -
        Component/s Calendar [ 12310749 ]
        sean schofield made changes -
        Workflow jira [ 12344740 ] MyFaces Workflow [ 12347509 ]
        sean schofield made changes -
        Field Original Value New Value
        Component/s Other [ 12310767 ]
        Project MyFaces Core [ 10600 ] MyFaces Tomahawk [ 12310272 ]
        Key MYFACES-940 TOMAHAWK-42
        Component/s Tomahawk [ 12310162 ]
        Sukhada added a comment -

        Try adding extension filter in web.xml.

        http://myfaces.apache.org/tomahawk/extensionsFilter.html

        Jane Skolnick created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Jane Skolnick
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development