MyFaces Tomahawk
  1. MyFaces Tomahawk
  2. TOMAHAWK-1618

ui:fragment ignores rendered attribute if nested in t:div

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.1.11
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      MyFaces 2.1.6, Tomahawk 1.1.11, Tomcat 6.0.32

      Description

      When nested inside a t:div, the rendered attribute of ui:fragment ist ignored.

      This seems to be similar to MYFACES-3239, which was fixed in 2.1.2.

      Example:

      <t:div>
      <ui:fragment rendered="false">
      <h:outputText value="This text should not appear" />
      </ui:fragment>
      </t:div>

      1. myfaces-blank.zip
        6.45 MB
        Patrick Schmidt

        Issue Links

          Activity

          Patrick Schmidt created issue -
          Patrick Schmidt made changes -
          Field Original Value New Value
          Attachment myfaces-blank.zip [ 12520420 ]
          Patrick Schmidt added a comment -

          Attached a sample eclipse project

          Leonardo Uribe made changes -
          Project MyFaces Core [ 10600 ] MyFaces Tomahawk [ 12310272 ]
          Key MYFACES-3517 TOMAHAWK-1618
          Affects Version/s 1.1.11 [ 12316480 ]
          Affects Version/s 2.1.6 [ 12319173 ]
          Component/s General [ 12310160 ]
          Leonardo Uribe added a comment -

          Thanks for the sample. It is a bug in tomahawk, and will be fixed updating shared module.

          Leonardo Uribe made changes -
          Link This issue duplicates TOMAHAWK-1616 [ TOMAHAWK-1616 ]
          Leonardo Uribe added a comment -

          This issue is a duplicate of TOMAHAWK-1616, so it will be closed.

          Leonardo Uribe made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Leonardo Uribe [ lu4242 ]
          Resolution Duplicate [ 3 ]

            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Patrick Schmidt
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development