MyFaces Tomahawk
  1. MyFaces Tomahawk
  2. TOMAHAWK-1505

varDetailToggler not functioning properly when sorting table

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.1.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Assume a table which has expandable details. There are three rows: C, B and A.
      If you expand the details for A, and then sort on the name, (so that the rows are now A, B and C)
      then after sorting, it's the details for C which are expanded.

      This would be considered a minor bug except that if the expanded details include user input controls (e.g. text input). If the user expands the details and enters data for A, then sort, the user entered data is now applied to row C instead of A.

        Issue Links

          Activity

          Stephen Cooper created issue -
          Stephen Cooper made changes -
          Field Original Value New Value
          Priority Critical [ 2 ] Major [ 3 ]
          Description Assume a table which has expandable details. There are three rows: C, B and A.
          If you expand the details for A, and then sort on the name, (so that the rows are now A, B and C)
          then after sorting, it's the details for C which are expanded.

          This would be considered a minor bug except that if the expanded details include user input controls (e.g. text input). If the user expands the details and enters data for A, then sort, the user entered data is now applied to row C instead of A.

          I'm using MyFaces this in a healthcare system, and this could lead to patient safety issues - e.g. comments entered for the wrong medication.
          Assume a table which has expandable details. There are three rows: C, B and A.
          If you expand the details for A, and then sort on the name, (so that the rows are now A, B and C)
          then after sorting, it's the details for C which are expanded.

          This would be considered a minor bug except that if the expanded details include user input controls (e.g. text input). If the user expands the details and enters data for A, then sort, the user entered data is now applied to row C instead of A.
          Stephen Cooper added a comment -

          As it turns out, sorting tables which have input components appears to be a dangerous thing to do in MyFaces. E.g. we have drop-down lists in our table, and if you enter data then sort (causing a form submission), the selections are applied to the wrong rows.

          Mike Kienenberger made changes -
          Link This issue relates to TOMAHAWK-961 [ TOMAHAWK-961 ]
          Mike Kienenberger added a comment -

          You can try the patch I created for https://issues.apache.org/jira/browse/TOMAHAWK-961

          Cagatay Civici made changes -
          Assignee Cagatay Civici [ cagatay_civici ]
          Leonardo Uribe made changes -
          Project MyFaces Core [ 10600 ] MyFaces Tomahawk [ 12310272 ]
          Key MYFACES-1696 TOMAHAWK-1505
          Affects Version/s 1.1.5 [ 12312397 ]
          Affects Version/s 1.1.5 [ 12312310 ]
          Component/s General [ 12310160 ]
          Leonardo Uribe added a comment -

          Duplicate of TOMAHAWK-961

          Leonardo Uribe made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Cagatay Civici [ cagatay_civici ] Leonardo Uribe [ lu4242 ]
          Resolution Duplicate [ 3 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          1320d 21h 21m 1 Leonardo Uribe 16/Mar/11 20:05

            People

            • Assignee:
              Leonardo Uribe
              Reporter:
              Stephen Cooper
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development