Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1.11
    • Component/s: Calendar
    • Labels:
      None
    • Environment:
      Opera 10.10

      Description

      When using Opera, the calendar opens in the wrong year (current year + 1900), although it´s correctly displayed in the calendar footer.

      1. popcalendar.js.diff
        8 kB
        Guilherme Garnier

        Activity

        Leonardo Uribe added a comment -

        I tested it with opera 10.10 and it is present. In opera 11 the problem is not present anymore.

        The solution is use getFullYear() instead and comment the code that adds 1900 to the year. This function is supported by all major browsers and by IE since 5.5 (ECMAScript 3). Anyway thanks for the patch.

        Guilherme Garnier added a comment -

        I fixed the bug, here is the diff file.

        The problem was related to getYear Javascript function. In IE and Opera, it returns the current year, and in other browsers (Firefox, Google Chrome) it returns the current year - 1900 (as defined in the specification). The solution to this is using getFullYear, which always returns the current year, in all browsers.

        This bug may be related to this:
        https://issues.apache.org/jira/browse/TOMAHAWK-39


          People

          • Assignee:
            Leonardo Uribe
            Reporter:
            Guilherme Garnier
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development